summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEtienne Cordonnier <ecordonnier@snap.com>2022-09-14 11:59:45 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-09-17 07:45:19 +0100
commita0892c3209e3892d79b97dcd4ec0e5a89057258c (patch)
tree071a592194763bef4670013c0a17ddcbd657649a
parent33c1dc903a0908dc9796ddf03a90f1e23e5d1405 (diff)
downloadopenembedded-core-a0892c3209e3892d79b97dcd4ec0e5a89057258c.tar.gz
opkg: add option for zstd support
This allows the use of zstd for opkg packages by using OPKGBUILDCMD: OPKGBUILDCMD = "opkg-build -Z zstd" Signed-off-by: Alex Feinman <afeinman@snap.com> Signed-off-by: Etienne Cordonnier <ecordonnier@snap.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/opkg/opkg_0.6.0.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-devtools/opkg/opkg_0.6.0.bb b/meta/recipes-devtools/opkg/opkg_0.6.0.bb
index 7b351e8123..4cd589cd29 100644
--- a/meta/recipes-devtools/opkg/opkg_0.6.0.bb
+++ b/meta/recipes-devtools/opkg/opkg_0.6.0.bb
@@ -39,6 +39,7 @@ PACKAGECONFIG[gpg] = "--enable-gpg,--disable-gpg,\
PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl"
PACKAGECONFIG[ssl-curl] = "--enable-ssl-curl,--disable-ssl-curl,curl openssl"
PACKAGECONFIG[sha256] = "--enable-sha256,--disable-sha256"
+PACKAGECONFIG[zstd] = "--enable-zstd,--disable-zstd,zstd"
PACKAGECONFIG[libsolv] = "--with-libsolv,--without-libsolv,libsolv"
EXTRA_OECONF:class-native = "--localstatedir=/${@os.path.relpath('${localstatedir}', '${STAGING_DIR_NATIVE}')} --sysconfdir=/${@os.path.relpath('${sysconfdir}', '${STAGING_DIR_NATIVE}')}"