summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2023-07-30 12:03:27 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-08-01 09:49:03 +0100
commit9351489f3fd9a01f1e74b4f209df01aeffe55c8f (patch)
tree7b38569e2a3bfddc2b170ce6d54b56c60984cbe1
parentfdd9e8fe947479994be02b61862e4b1604f44f2d (diff)
downloadopenembedded-core-9351489f3fd9a01f1e74b4f209df01aeffe55c8f.tar.gz
python3-more-itertools: upgrade 9.1.0 -> 10.0.0
https://more-itertools.readthedocs.io/en/stable/versions.html 10.0.0 * Potentially breaking changes - Python 3.7 support was dropped, since it went EOL on 2023-06-27 - batched() no longer issues a DeprecationWarning; it is now an alias for itertools.batched for Python 3.12+ - batched() and matmul() now yield tuples instead of lists * New functions - combination_with_replacement_index() (thanks to Schoyen) - nth_combination_with_replacement() (thanks to Schoyen) - polynomial_eval() (from the Python itertools docs) - polynomial_derivative() (from the Python itertools docs) - sum_of_squares() (from the Python itertools docs) * Changes to existing functions - seekable() now has relative_seek method (thanks to karlb) - chunked_even() was optimized (thanks to elliotwutingfeng) - numeric_range() was optimized (thanks to eltoder) - duplicates_justseen(), pairwise(), partial_product(), and partition() were updated and optimized (thanks to pochmann) - unique_in_window() had its implementation updated (thanks to elliotwutingfeng) - iterate() now breaks when its func argument raises StopIteration (thanks to jrebiffe) * Other changes - Some documentation and testing issues were fixed (thanks to lonnen and XuehaiPan) Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/python/python3-more-itertools_10.0.0.bb (renamed from meta/recipes-devtools/python/python3-more-itertools_9.1.0.bb)2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python3-more-itertools_9.1.0.bb b/meta/recipes-devtools/python/python3-more-itertools_10.0.0.bb
index 8c33b7161b..e07d4b7860 100644
--- a/meta/recipes-devtools/python/python3-more-itertools_9.1.0.bb
+++ b/meta/recipes-devtools/python/python3-more-itertools_10.0.0.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "https://github.com/erikrose/more-itertools"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=3396ea30f9d21389d7857719816f83b5"
-SRC_URI[sha256sum] = "cabaa341ad0389ea83c17a94566a53ae4c9d07349861ecb14dc6d0345cf9ac5d"
+SRC_URI[sha256sum] = "cd65437d7c4b615ab81c0640c0480bc29a550ea032891977681efd28344d51e1"
inherit pypi python_flit_core ptest