summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2023-05-09 19:23:43 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-05-22 10:53:44 +0100
commit9012ad6f3bdda5ca669c20ade397ec45d2bed731 (patch)
tree91d204415affc62366d569fea645344f018aec16
parent6f0c3844e3ced175416daac645179a3044df6bcf (diff)
downloadopenembedded-core-9012ad6f3bdda5ca669c20ade397ec45d2bed731.tar.gz
createrepo-c: update 0.20.1 -> 0.21.1
Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
-rw-r--r--meta/recipes-devtools/createrepo-c/createrepo-c/0001-include-rpm-rpmstring.h.patch9
-rw-r--r--meta/recipes-devtools/createrepo-c/createrepo-c/0001-src-cmd_parser.c-add-a-missing-parameter-name.patch39
-rw-r--r--meta/recipes-devtools/createrepo-c/createrepo-c_0.21.1.bb (renamed from meta/recipes-devtools/createrepo-c/createrepo-c_0.20.1.bb)3
3 files changed, 47 insertions, 4 deletions
diff --git a/meta/recipes-devtools/createrepo-c/createrepo-c/0001-include-rpm-rpmstring.h.patch b/meta/recipes-devtools/createrepo-c/createrepo-c/0001-include-rpm-rpmstring.h.patch
index a249eaf5a1..b7e5710b39 100644
--- a/meta/recipes-devtools/createrepo-c/createrepo-c/0001-include-rpm-rpmstring.h.patch
+++ b/meta/recipes-devtools/createrepo-c/createrepo-c/0001-include-rpm-rpmstring.h.patch
@@ -1,7 +1,7 @@
-From 8defe6aaf91613c3fcb540df65a94cd56d377367 Mon Sep 17 00:00:00 2001
+From eb66326c3fc6e942282d01ddd56659c78ed7400b Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Fri, 13 Jan 2023 13:21:51 -0800
-Subject: [PATCH 1/2] include rpm/rpmstring.h
+Subject: [PATCH] include rpm/rpmstring.h
Its needed for rasprintf declaration
@@ -11,10 +11,13 @@ on 'rasprintf'; ISO C99 and later do not support implicit function declarations
Upstream-Status: Submitted [https://github.com/rpm-software-management/createrepo_c/pull/340]
Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
---
src/xml_file.c | 1 +
1 file changed, 1 insertion(+)
+diff --git a/src/xml_file.c b/src/xml_file.c
+index d2400b8..871109c 100644
--- a/src/xml_file.c
+++ b/src/xml_file.c
@@ -19,6 +19,7 @@
@@ -23,5 +26,5 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
#include <glib/gstdio.h>
+#include <rpm/rpmstring.h>
#include <assert.h>
+ #include <rpm/rpmstring.h>
#include "xml_file.h"
- #include <errno.h>
diff --git a/meta/recipes-devtools/createrepo-c/createrepo-c/0001-src-cmd_parser.c-add-a-missing-parameter-name.patch b/meta/recipes-devtools/createrepo-c/createrepo-c/0001-src-cmd_parser.c-add-a-missing-parameter-name.patch
new file mode 100644
index 0000000000..0d1c6b08fb
--- /dev/null
+++ b/meta/recipes-devtools/createrepo-c/createrepo-c/0001-src-cmd_parser.c-add-a-missing-parameter-name.patch
@@ -0,0 +1,39 @@
+From 970b901e1999f415da8bac205f526c808ddad0ba Mon Sep 17 00:00:00 2001
+From: Alexander Kanavin <alex@linutronix.de>
+Date: Mon, 8 May 2023 10:40:43 +0200
+Subject: [PATCH] src/cmd_parser.c: add a missing parameter name
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+This resolves the following error with older versions of gcc:
+| /srv/storage/alex/yocto/build-32/tmp/work/x86_64-linux/createrepo-c-native/0.21.1-r0/git/src/cmd_parser.c: In function ‘duplicated_nevra_option_parser’:
+| /srv/storage/alex/yocto/build-32/tmp/work/x86_64-linux/createrepo-c-native/0.21.1-r0/git/src/cmd_parser.c:76:32: error: parameter name omitted
+| 76 | duplicated_nevra_option_parser(const gchar *,
+| | ^~~~~~~~~~~~~
+| /srv/storage/alex/yocto/build-32/tmp/work/x86_64-linux/createrepo-c-native/0.21.1-r0/git/src/cmd_parser.c:78:32: error: parameter name omitted
+| 78 | gpointer,
+| | ^~~~~~~~
+
+Upstream-Status: Submitted [https://github.com/rpm-software-management/createrepo_c/pull/366]
+Signed-off-by: Alexander Kanavin <alex@linutronix.de>
+---
+ src/cmd_parser.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/cmd_parser.c b/src/cmd_parser.c
+index 97c9ea7..63af7ea 100644
+--- a/src/cmd_parser.c
++++ b/src/cmd_parser.c
+@@ -73,9 +73,9 @@ struct CmdOptions _cmd_options = {
+
+
+ gboolean
+-duplicated_nevra_option_parser(const gchar *,
++duplicated_nevra_option_parser(const gchar *option_name,
+ const gchar *value,
+- gpointer,
++ gpointer data,
+ GError **error)
+ {
+ if (!g_strcmp0(value, "keep"))
diff --git a/meta/recipes-devtools/createrepo-c/createrepo-c_0.20.1.bb b/meta/recipes-devtools/createrepo-c/createrepo-c_0.21.1.bb
index 1c4cdd5e3c..5080131dc1 100644
--- a/meta/recipes-devtools/createrepo-c/createrepo-c_0.20.1.bb
+++ b/meta/recipes-devtools/createrepo-c/createrepo-c_0.21.1.bb
@@ -7,9 +7,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
SRC_URI = "git://github.com/rpm-software-management/createrepo_c;branch=master;protocol=https \
file://0001-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \
file://0001-include-rpm-rpmstring.h.patch \
+ file://0001-src-cmd_parser.c-add-a-missing-parameter-name.patch \
"
-SRCREV = "af14e164a3e4ab9dfaef1212e852b9ecebc326a2"
+SRCREV = "0652d7303ce236e596c83c29ccc9bee7868fce6e"
S = "${WORKDIR}/git"