summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2022-12-02 17:37:38 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-12-05 22:28:10 +0000
commit8de9d28a57cae405dd76aa2bca7a81507718817d (patch)
tree068440e9fd8995e719d8ce978b3df55f2ac696ff
parentd37c2d428b09b9d0cbb875f083c6a1e9883a7fed (diff)
downloadopenembedded-core-8de9d28a57cae405dd76aa2bca7a81507718817d.tar.gz
python3: fix tests on x86 (32 bit)
Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
-rw-r--r--meta/recipes-devtools/python/python3/0001-test_marshal.py-add-more-elements-in-test_determinis.patch27
-rw-r--r--meta/recipes-devtools/python/python3_3.11.0.bb1
2 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3/0001-test_marshal.py-add-more-elements-in-test_determinis.patch b/meta/recipes-devtools/python/python3/0001-test_marshal.py-add-more-elements-in-test_determinis.patch
new file mode 100644
index 0000000000..9da7f94255
--- /dev/null
+++ b/meta/recipes-devtools/python/python3/0001-test_marshal.py-add-more-elements-in-test_determinis.patch
@@ -0,0 +1,27 @@
+From 076a4f9ab06105b94c87386c0dfe17b823502a13 Mon Sep 17 00:00:00 2001
+From: Alexander Kanavin <alex@linutronix.de>
+Date: Thu, 1 Dec 2022 19:02:51 +0100
+Subject: [PATCH] test_marshal.py: add more elements in test_deterministic_sets
+
+Existing elements do produce different output on x86_64, but they
+do not on x86. Let's make the data longer to ensure it differs.
+
+Upstream-Status: Submitted [https://github.com/python/cpython/pull/99935]
+Signed-off-by: Alexander Kanavin <alex@linutronix.de>
+---
+ Lib/test/test_marshal.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Lib/test/test_marshal.py b/Lib/test/test_marshal.py
+index aae86cc..29d95ad 100644
+--- a/Lib/test/test_marshal.py
++++ b/Lib/test/test_marshal.py
+@@ -352,7 +352,7 @@ class BugsTestCase(unittest.TestCase):
+ for elements in (
+ "float('nan'), b'a', b'b', b'c', 'x', 'y', 'z'",
+ # Also test for bad interactions with backreferencing:
+- "('Spam', 0), ('Spam', 1), ('Spam', 2)",
++ "('Spam', 0), ('Spam', 1), ('Spam', 2), ('Spam', 3), ('Spam', 4), ('Spam', 5)",
+ ):
+ s = f"{kind}([{elements}])"
+ with self.subTest(s):
diff --git a/meta/recipes-devtools/python/python3_3.11.0.bb b/meta/recipes-devtools/python/python3_3.11.0.bb
index 16a9e04cc9..c4fa8c65cd 100644
--- a/meta/recipes-devtools/python/python3_3.11.0.bb
+++ b/meta/recipes-devtools/python/python3_3.11.0.bb
@@ -35,6 +35,7 @@ SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.xz \
file://deterministic_imports.patch \
file://0001-Avoid-shebang-overflow-on-python-config.py.patch \
file://cve-2022-37460.patch \
+ file://0001-test_marshal.py-add-more-elements-in-test_determinis.patch \
"
SRC_URI:append:class-native = " \