summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2023-01-11 14:17:53 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-01-12 23:07:39 +0000
commit3ed3b2ffeeaa5d888f77dd30cb8cd81d3275398a (patch)
treed6a78d940eb8cdea245084be19c847c4bcfbc025
parent76f1e8c9f8306ed0f0db42dd7a3c7efce82108ce (diff)
downloadopenembedded-core-3ed3b2ffeeaa5d888f77dd30cb8cd81d3275398a.tar.gz
curl: don't enable debug builds
In oe-core 27824261 --enable-debug was added to the configure arguments to turn on debugging symbols. However, enabling debug mode does more than turn on debugging symbols and introduces some codepaths that can be controlled with environment variables. Bluntly, the curl maintainer says that --enable-debug should not be used in production: https://curl.se/mail/lib-2023-01/0039.html I did a build and verified that the curl-dbg package doesn't massively shrink, so the debug symbols are still being built. Remove the debug options and hide them behind a PACKAGECONFIG, with a comment that it should not be used in production. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-support/curl/curl_7.87.0.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-support/curl/curl_7.87.0.bb b/meta/recipes-support/curl/curl_7.87.0.bb
index a3ad66f1aa..9956a28422 100644
--- a/meta/recipes-support/curl/curl_7.87.0.bb
+++ b/meta/recipes-support/curl/curl_7.87.0.bb
@@ -32,6 +32,8 @@ PACKAGECONFIG:class-nativesdk = "ipv6 openssl proxy random threaded-resolver ver
PACKAGECONFIG[ares] = "--enable-ares,--disable-ares,c-ares,,,threaded-resolver"
PACKAGECONFIG[brotli] = "--with-brotli,--without-brotli,brotli"
PACKAGECONFIG[builtinmanual] = "--enable-manual,--disable-manual"
+# Don't use this in production
+PACKAGECONFIG[debug] = "--enable-debug,--disable-debug"
PACKAGECONFIG[dict] = "--enable-dict,--disable-dict,"
PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls"
PACKAGECONFIG[gopher] = "--enable-gopher,--disable-gopher,"
@@ -68,9 +70,7 @@ EXTRA_OECONF = " \
--enable-crypto-auth \
--with-ca-bundle=${sysconfdir}/ssl/certs/ca-certificates.crt \
--without-libpsl \
- --enable-debug \
--enable-optimize \
- --disable-curldebug \
${@'--without-ssl' if (bb.utils.filter('PACKAGECONFIG', 'gnutls mbedtls nss openssl', d) == '') else ''} \
"