summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2023-03-09 22:00:48 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-03-12 23:36:44 +0000
commit27b6605c7b95f70a50b4243818a03c5b2412c5a6 (patch)
tree2f915344b810090b9255771d23b213bbafc190a7
parent6c472b326bcc718459483cc29b310b884742df86 (diff)
downloadopenembedded-core-27b6605c7b95f70a50b4243818a03c5b2412c5a6.tar.gz
m4/opkg/ethtool/attr/libgpg-error: Add missing bash ptest dependency
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/m4/m4-1.4.19.inc2
-rw-r--r--meta/recipes-devtools/opkg/opkg_0.6.1.bb2
-rw-r--r--meta/recipes-extended/ethtool/ethtool_6.2.bb2
-rw-r--r--meta/recipes-support/attr/attr.inc1
-rw-r--r--meta/recipes-support/libgpg-error/libgpg-error_1.46.bb2
5 files changed, 5 insertions, 4 deletions
diff --git a/meta/recipes-devtools/m4/m4-1.4.19.inc b/meta/recipes-devtools/m4/m4-1.4.19.inc
index c098a4077e..fd3efa5469 100644
--- a/meta/recipes-devtools/m4/m4-1.4.19.inc
+++ b/meta/recipes-devtools/m4/m4-1.4.19.inc
@@ -53,7 +53,7 @@ do_install_ptest() {
}
-RDEPENDS:${PN}-ptest += "make coreutils diffutils"
+RDEPENDS:${PN}-ptest += "make coreutils diffutils bash"
RDEPENDS:${PN}-ptest:append:libc-glibc = "\
locale-base-fr-fr \
locale-base-fr-fr.iso-8859-1 \
diff --git a/meta/recipes-devtools/opkg/opkg_0.6.1.bb b/meta/recipes-devtools/opkg/opkg_0.6.1.bb
index c95a40d268..c3f4a7dd57 100644
--- a/meta/recipes-devtools/opkg/opkg_0.6.1.bb
+++ b/meta/recipes-devtools/opkg/opkg_0.6.1.bb
@@ -65,7 +65,7 @@ do_install_ptest () {
RDEPENDS:${PN} = "${VIRTUAL-RUNTIME_update-alternatives} opkg-arch-config libarchive"
RDEPENDS:${PN}:class-native = ""
RDEPENDS:${PN}:class-nativesdk = ""
-RDEPENDS:${PN}-ptest += "make binutils python3-core python3-compression"
+RDEPENDS:${PN}-ptest += "make binutils python3-core python3-compression bash"
RREPLACES:${PN} = "opkg-nogpg opkg-collateral"
RCONFLICTS:${PN} = "opkg-collateral"
RPROVIDES:${PN} = "opkg-collateral"
diff --git a/meta/recipes-extended/ethtool/ethtool_6.2.bb b/meta/recipes-extended/ethtool/ethtool_6.2.bb
index 881e638851..aea03b729d 100644
--- a/meta/recipes-extended/ethtool/ethtool_6.2.bb
+++ b/meta/recipes-extended/ethtool/ethtool_6.2.bb
@@ -17,7 +17,7 @@ UPSTREAM_CHECK_URI = "https://www.kernel.org/pub/software/network/ethtool/"
inherit autotools ptest bash-completion pkgconfig
-RDEPENDS:${PN}-ptest += "make"
+RDEPENDS:${PN}-ptest += "make bash"
PACKAGECONFIG ?= "netlink"
PACKAGECONFIG[netlink] = "--enable-netlink,--disable-netlink,libmnl,"
diff --git a/meta/recipes-support/attr/attr.inc b/meta/recipes-support/attr/attr.inc
index a4e38f2b19..53d9dccb27 100644
--- a/meta/recipes-support/attr/attr.inc
+++ b/meta/recipes-support/attr/attr.inc
@@ -49,6 +49,7 @@ do_install_ptest() {
}
RDEPENDS:${PN}-ptest = "attr \
+ bash \
coreutils \
perl-module-filehandle \
perl-module-getopt-std \
diff --git a/meta/recipes-support/libgpg-error/libgpg-error_1.46.bb b/meta/recipes-support/libgpg-error/libgpg-error_1.46.bb
index 580fe208d4..e0f2d86303 100644
--- a/meta/recipes-support/libgpg-error/libgpg-error_1.46.bb
+++ b/meta/recipes-support/libgpg-error/libgpg-error_1.46.bb
@@ -26,7 +26,7 @@ BINCONFIG = "${bindir}/gpg-error-config"
inherit autotools binconfig-disabled pkgconfig gettext multilib_header multilib_script ptest
-RDEPENDS:${PN}-ptest:append = " make"
+RDEPENDS:${PN}-ptest:append = " make bash"
MULTILIB_SCRIPTS = "${PN}-dev:${bindir}/gpgrt-config"