summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-02-06 22:02:39 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-02-08 23:14:49 +0000
commit0f5a64aecec9d50b50e2ca70bb1a7e4b680bc4ce (patch)
treedccafaf3af5bad8b394c0486ad3ee40243cfd068
parenta19af24fc910bbfc39c863e3252770aa9975de5b (diff)
downloadopenembedded-core-0f5a64aecec9d50b50e2ca70bb1a7e4b680bc4ce.tar.gz
expat: Upgrade to 2.6.0
Package and run benchmark as part of ptest This is a major release with following changes [1] [1] https://github.com/libexpat/libexpat/blob/R_2_6_0/expat/Changes Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/expat/expat/run-ptest2
-rw-r--r--meta/recipes-core/expat/expat_2.6.0.bb (renamed from meta/recipes-core/expat/expat_2.5.0.bb)5
2 files changed, 4 insertions, 3 deletions
diff --git a/meta/recipes-core/expat/expat/run-ptest b/meta/recipes-core/expat/expat/run-ptest
index dbf602ca80..ff7986db3c 100644
--- a/meta/recipes-core/expat/expat/run-ptest
+++ b/meta/recipes-core/expat/expat/run-ptest
@@ -5,5 +5,5 @@ TIME=$(which time)
echo "runtests"
${TIME} -f 'Execution time: %e s' bash -c "./runtests -v"
echo "runtestspp"
-${TIME} -f 'Execution time: %e s' bash -c "./runtestspp -v"
+${TIME} -f 'Execution time: %e s' bash -c "./runtests_cxx -v"
echo
diff --git a/meta/recipes-core/expat/expat_2.5.0.bb b/meta/recipes-core/expat/expat_2.6.0.bb
index aa8d439d5f..1f9f7b269a 100644
--- a/meta/recipes-core/expat/expat_2.5.0.bb
+++ b/meta/recipes-core/expat/expat_2.6.0.bb
@@ -15,7 +15,7 @@ SRC_URI = "${GITHUB_BASE_URI}/download/R_${VERSION_TAG}/expat-${PV}.tar.bz2 \
GITHUB_BASE_URI = "https://github.com/libexpat/libexpat/releases/"
UPSTREAM_CHECK_REGEX = "releases/tag/R_(?P<pver>.+)"
-SRC_URI[sha256sum] = "6f0e6e01f7b30025fa05c85fdad1e5d0ec7fd35d9f61b22f34998de11969ff67"
+SRC_URI[sha256sum] = "ff60e6a6b6ce570ae012dc7b73169c7fdf4b6bf08c12ed0ec6f55736b78d85ba"
EXTRA_OECMAKE:class-native += "-DEXPAT_BUILD_DOCS=OFF"
@@ -24,7 +24,8 @@ RDEPENDS:${PN}-ptest += "bash"
inherit cmake lib_package ptest github-releases
do_install_ptest:class-target() {
- install -m 755 ${B}/tests/* ${D}${PTEST_PATH}
+ install -m 755 ${B}/tests/runtests* ${D}${PTEST_PATH}
+ install -m 755 ${B}/tests/benchmark/benchmark ${D}${PTEST_PATH}
}
BBCLASSEXTEND += "native nativesdk"