summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2022-11-10 19:12:31 +0100
committerSteve Sakoman <steve@sakoman.com>2022-11-21 06:39:37 -1000
commite8258f174fb124f87051eae60195638f625afd67 (patch)
tree4c3d675e5d495af80ac8b850efc4486cc6b58b8f
parent0a449acddca1ba9022c9ffd8af0d9ac5ad2c4e4c (diff)
downloadopenembedded-core-e8258f174fb124f87051eae60195638f625afd67.tar.gz
pango: replace a recipe fix with an upstream submitted patch
Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> (cherry picked from commit f444e01e0230904510f50d1b093d75253faf1bca) Signed-off-by: Steve Sakoman <steve@sakoman.com>
-rw-r--r--meta/recipes-graphics/pango/pango/0001-tests-meson.build-install-nofonts-fonts.conf-as-it-i.patch35
-rw-r--r--meta/recipes-graphics/pango/pango_1.50.11.bb13
2 files changed, 38 insertions, 10 deletions
diff --git a/meta/recipes-graphics/pango/pango/0001-tests-meson.build-install-nofonts-fonts.conf-as-it-i.patch b/meta/recipes-graphics/pango/pango/0001-tests-meson.build-install-nofonts-fonts.conf-as-it-i.patch
new file mode 100644
index 0000000000..8dacd62138
--- /dev/null
+++ b/meta/recipes-graphics/pango/pango/0001-tests-meson.build-install-nofonts-fonts.conf-as-it-i.patch
@@ -0,0 +1,35 @@
+From 13f8ba5d5b699df1f88eeea859406daba6d6941f Mon Sep 17 00:00:00 2001
+From: Alexander Kanavin <alex@linutronix.de>
+Date: Tue, 8 Nov 2022 18:08:51 +0100
+Subject: [PATCH] tests/meson.build: install nofonts/fonts.conf as it is
+ required by tests
+
+Upstream-Status: Submitted [https://gitlab.gnome.org/GNOME/pango/-/merge_requests/654]
+Signed-off-by: Alexander Kanavin <alex@linutronix.de>
+---
+ tests/meson.build | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/tests/meson.build b/tests/meson.build
+index 8b4bfa38..6c1c461b 100644
+--- a/tests/meson.build
++++ b/tests/meson.build
+@@ -250,6 +250,10 @@ foreach d: test_items_data
+ installed_test_items_data += d + '.expected'
+ endforeach
+
++installed_test_nofonts_data = [
++ 'nofonts/fonts.conf',
++]
++
+ installed_test_datadir = join_paths(pango_datadir, 'installed-tests', 'pango')
+ installed_test_bindir = join_paths(pango_libexecdir, 'installed-tests', 'pango')
+
+@@ -261,6 +265,7 @@ if get_option('install-tests')
+ install_data(installed_test_breaks_data, install_dir: join_paths(installed_test_bindir, 'breaks'))
+ install_data(installed_test_items_data, install_dir: join_paths(installed_test_bindir, 'itemize'))
+ install_data(installed_test_fontsets_data, install_dir: join_paths(installed_test_bindir, 'fontsets'))
++ install_data(installed_test_nofonts_data, install_dir: join_paths(installed_test_bindir, 'nofonts'))
+ endif
+
+ gen_installed_test = files([ 'gen-installed-test.py' ])
diff --git a/meta/recipes-graphics/pango/pango_1.50.11.bb b/meta/recipes-graphics/pango/pango_1.50.11.bb
index f982d9a65b..6f599f5b78 100644
--- a/meta/recipes-graphics/pango/pango_1.50.11.bb
+++ b/meta/recipes-graphics/pango/pango_1.50.11.bb
@@ -21,8 +21,9 @@ GIR_MESON_ENABLE_FLAG = "enabled"
GIR_MESON_DISABLE_FLAG = "disabled"
SRC_URI += "file://run-ptest \
- file://0001-Skip-running-test-layout-test.patch \
-"
+ file://0001-Skip-running-test-layout-test.patch \
+ file://0001-tests-meson.build-install-nofonts-fonts.conf-as-it-i.patch \
+ "
SRC_URI[archive.sha256sum] = "8800f812d89ee61388188703203f3a7878963c22f8695aaf1fa0a1a1428d17ae"
@@ -41,14 +42,6 @@ do_configure:prepend() {
chmod +x ${S}/tests/*.py
}
-# https://gitlab.gnome.org/GNOME/pango/-/issues/713
-do_install:append() {
- if [ "${@bb.utils.filter('PACKAGECONFIG', 'tests', d)}" ]; then
- mkdir -p ${D}${libexecdir}/installed-tests/pango/nofonts
- install ${S}/tests/nofonts/fonts.conf ${D}${libexecdir}/installed-tests/pango/nofonts
- fi
-}
-
LEAD_SONAME = "libpango-1.0*"
FILES:${PN} = "${bindir}/* ${libdir}/libpango*${SOLIBS}"