summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2022-11-18 17:28:51 -0500
committerSteve Sakoman <steve@sakoman.com>2022-11-29 06:30:24 -1000
commit141d71c2cf8548900586893178b9097cd723ba57 (patch)
tree6fc8d160aa2bac74334c85500f49b3bb7ddd7f7b
parent52e2d574626075e2890021f1ede127c5eabd92b7 (diff)
downloadopenembedded-core-141d71c2cf8548900586893178b9097cd723ba57.tar.gz
kern-tools: integrate ZFS speedup patch
Bumping the SRCREV to integrat the following kern-tools change: commit 2d01f24bc78256c709728eb3f204491bce13e0e5 Author: Volodymyr Babchuk <Volodymyr_Babchuk@epam.com> Date: Fri Nov 4 23:32:38 2022 +0000 kconf_check: store some files in tmpdir Some file systems, like ZFS, are very slow at appending to existing files. Due to Copy-On-Write nature, they create a new copy of a file each time we do ">>" in a shell script. This becomes very noticeable if shell script does lots and lots of appends, like sanitize_fragment() function in kconf_check. On my setup, do_kernel_configcheck task takes literally hours to complete. To fix this issue, we can store sanitized_list and fragment_errors.txt files on tmpfs, which is extremely fast at writing. As most distros use tmpfs for /tmp, logical step is to use `mktemp` to create temporary files. After completing writing to temporary locations, we can move those two files back to ${LOGDIR}. Also, function 'cleanup' was added to remove temporary files in case of abnormal exit. With this patch, do_kernel_configcheck task completes in ~2 minutes on my setup, which is a great improvement. Signed-off-by: Volodymyr Babchuk <volodymyr_babchuk@epam.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> (cherry picked from commit 9d50e2606eb66019044ee176f355a84a65a1499c) Signed-off-by: Steve Sakoman <steve@sakoman.com>
-rw-r--r--meta/recipes-kernel/kern-tools/kern-tools-native_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb b/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
index 07d7daf5fb..12f1cf516e 100644
--- a/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
+++ b/meta/recipes-kernel/kern-tools/kern-tools-native_git.bb
@@ -11,7 +11,7 @@ LIC_FILES_CHKSUM = "\
DEPENDS = "git-native"
-SRCREV = "6a4752ebbe7d242c02b3c74a5772926edd243626"
+SRCREV = "2d01f24bc78256c709728eb3f204491bce13e0e5"
PV = "0.3+git${SRCPV}"
inherit native