summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorZhai Edwin <edwin.zhai@intel.com>2010-07-21 15:06:16 +0800
committerRichard Purdie <rpurdie@linux.intel.com>2010-07-21 16:00:58 +0100
commit7dcb5a2ea66fae6f4aa77c44b68be77a4794450f (patch)
treebb876efacc7b2578229346a71c3488eb46b4a81f /meta
parent3668c10acb3aff3776e67d000cf6dce9e46f5d75 (diff)
downloadopenembedded-core-contrib-7dcb5a2ea66fae6f4aa77c44b68be77a4794450f.tar.gz
gpgme: Update to 1.3.0
gpgme 1.3.0 requires gpgconf&g13 from gnupg, otherwise got configure failure. Adding gnupg need a lot of efforts and still has issue:g13 only exist in development branch. So add a patch to disable the check error, just like non-cross-compile environment. Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/packages/gpgme/gpgme-1.3.0/disable_gpgconf_check.patch38
-rw-r--r--meta/packages/gpgme/gpgme_1.3.0.bb (renamed from meta/packages/gpgme/gpgme_1.1.4.bb)13
2 files changed, 48 insertions, 3 deletions
diff --git a/meta/packages/gpgme/gpgme-1.3.0/disable_gpgconf_check.patch b/meta/packages/gpgme/gpgme-1.3.0/disable_gpgconf_check.patch
new file mode 100644
index 0000000000..f56f35b9ed
--- /dev/null
+++ b/meta/packages/gpgme/gpgme-1.3.0/disable_gpgconf_check.patch
@@ -0,0 +1,38 @@
+From 1.2.0, gpgme will check if gpgconf & g13(from 1.3.0) exist, and cause
+configure failure if not founding them in cross-compile environment. We can
+add the gnupg-native to get them, but still have some issues:
+
+1. need add new package: libksba, update libassuan(not in sato), and extend
+ native support in some other packages(libgcrypt, libgpg-error, pth...)
+2. Even we have gnupg, the g13 only exist in development branch, so that we
+ still have the g13 check failure in configure.
+
+I have searched the compile log, and found gpgconf/g13 are not used. So use a
+simple method here, throw a warning mesg rather than an error here just like in
+non-cross-compile environment.
+
+Signed-off-by: Zhai Edwin <edwin.zhai@intel.com>
+
+
+Index: gpgme-1.3.0/configure.ac
+===================================================================
+--- gpgme-1.3.0.orig/configure.ac 2010-07-21 09:38:09.000000000 +0800
++++ gpgme-1.3.0/configure.ac 2010-07-21 09:39:19.000000000 +0800
+@@ -574,7 +574,7 @@
+ *** Could not find gpgconf, install gpgconf or use --with-gpgconf=PATH to enable it
+ ***])
+ else
+- AC_MSG_ERROR([
++ AC_MSG_WARN([
+ ***
+ *** Can not determine path to gpgconf when cross-compiling, use --with-gpgconf=PATH
+ ***])
+@@ -670,7 +670,7 @@
+ *** Could not find g13, install g13 or use --with-g13=PATH to enable it
+ ***])
+ else
+- AC_MSG_ERROR([
++ AC_MSG_WARN([
+ ***
+ *** Can not determine path to g13 when cross-compiling, use --with-g13=PATH
+ ***])
diff --git a/meta/packages/gpgme/gpgme_1.1.4.bb b/meta/packages/gpgme/gpgme_1.3.0.bb
index fa1632b94d..1c665b5ea4 100644
--- a/meta/packages/gpgme/gpgme_1.1.4.bb
+++ b/meta/packages/gpgme/gpgme_1.3.0.bb
@@ -1,10 +1,17 @@
DESCRIPTION = "GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier for applications. It provides a High-Level Crypto API for encryption, decryption, signing, signature verification and key management"
HOMEPAGE = "http://www.gnupg.org/gpgme.html"
+BUGTRACKER = "https://bugs.g10code.com/gnupg/index"
+
LICENSE = "GPLv2+ & LGPLv2.1+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
+ file://COPYING.LESSER;md5=bbb461211a33b134d42ed5ee802b37ff \
+ file://src/gpgme.h;endline=23;md5=2775a99d3dd524c4f848ff1c59093038 \
+ file://src/engine.h;endline=22;md5=e96acfaab1cff82dd8fbefddd2f5c436"
-SRC_URI = "ftp://ftp.gnupg.org/gcrypt/gpgme/gpgme-${PV}.tar.bz2"
-DEPENDS = "libgpg-error pth"
-PR = "r4"
+SRC_URI = "ftp://ftp.gnupg.org/gcrypt/gpgme/gpgme-${PV}.tar.bz2 \
+ file://disable_gpgconf_check.patch;patch=1;pnum=1"
+DEPENDS = "libgpg-error libassuan pth"
+PR = "r0"
EXTRA_OECONF = "--with-pth=${STAGING_DIR_HOST} --without-pth-test \
--with-gpg=${bindir}/gpg --without-gpgsm"