summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2022-02-17 17:09:26 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-02-17 17:56:52 +0000
commit7070f8a4ce56656720b43cbb68097f46d9213bdc (patch)
treef1c22bfddd9ebaa2c2d7d17011816d9e8f5ad084 /meta
parent0ad97879bb13d542d5b475376805af87cdeb6837 (diff)
downloadopenembedded-core-contrib-7070f8a4ce56656720b43cbb68097f46d9213bdc.tar.gz
repo: upgrade 2.20 -> 2.21
sed-patch the sources from do_configure, as otherwise this breaks automated updates (devtool creates a patch out of changes done by sed). Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/repo/repo_2.21.bb (renamed from meta/recipes-devtools/repo/repo_2.20.bb)8
1 files changed, 3 insertions, 5 deletions
diff --git a/meta/recipes-devtools/repo/repo_2.20.bb b/meta/recipes-devtools/repo/repo_2.21.bb
index b56559fd9a..3c50793401 100644
--- a/meta/recipes-devtools/repo/repo_2.20.bb
+++ b/meta/recipes-devtools/repo/repo_2.21.bb
@@ -12,18 +12,16 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
SRC_URI = "git://gerrit.googlesource.com/git-repo.git;protocol=https;branch=main \
file://0001-python3-shebang.patch \
"
-SRCREV = "98bb76577d9e7e0ffdeb643f1654ec006f6bbc8c"
+SRCREV = "8e91248655acf1c8044ed8c1b265b804a99eb07f"
MIRRORS += "git://gerrit.googlesource.com/git-repo.git git://github.com/GerritCodeReview/git-repo.git"
S = "${WORKDIR}/git"
-do_set_fixed_rev() {
- sed -Ei "s/REPO_REV\s*=\s*('|\")stable('|\")/REPO_REV = '${SRCREV}'/g" ${S}/repo
+do_configure:prepend() {
+ sed -Ei "s/REPO_REV\s*=\s*('|\")stable('|\")/REPO_REV = '${SRCREV}'/g" ${S}/repo
}
-do_patch[postfuncs] += "do_set_fixed_rev"
-
do_install() {
install -D ${WORKDIR}/git/repo ${D}${bindir}/repo
}