summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/qemu/qemu_4.0.0.bb
diff options
context:
space:
mode:
authorAlistair Francis <Alistair.Francis@wdc.com>2019-05-02 04:09:27 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-05-02 13:42:56 +0100
commitfed2a0f37a76732cd3de1b127d6902fb16dd4e05 (patch)
treef78234452605c8cdc7fa95327e385342650e568b /meta/recipes-devtools/qemu/qemu_4.0.0.bb
parentde1782b23f8a98df3b42cb57bbcdff690bfa2343 (diff)
downloadopenembedded-core-contrib-fed2a0f37a76732cd3de1b127d6902fb16dd4e05.tar.gz
qemu: Upgrade from 3.1.0 to 4.0.0
This commit upgrade QEMU to the latest 4.0.0 release. - The COPYING.LIB file has changed SHA to: "Synchronize the LGPL 2.1 with the version from gnu.org" - SDL 1.2 has been removed, along with the --with-sdlabi command line arg - The backported patches have been removed - Al the other patches have been refreshed and the numbering has been updated Signed-off-by: Alistair Francis <alistair.francis@wdc.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/qemu/qemu_4.0.0.bb')
-rw-r--r--meta/recipes-devtools/qemu/qemu_4.0.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-devtools/qemu/qemu_4.0.0.bb b/meta/recipes-devtools/qemu/qemu_4.0.0.bb
new file mode 100644
index 0000000000..247e0311ed
--- /dev/null
+++ b/meta/recipes-devtools/qemu/qemu_4.0.0.bb
@@ -0,0 +1,20 @@
+BBCLASSEXTEND = "nativesdk"
+
+require qemu.inc
+
+DEPENDS = "glib-2.0 zlib pixman"
+
+RDEPENDS_${PN}_class-target += "bash"
+
+EXTRA_OECONF_append_class-target = " --target-list=${@get_qemu_target_list(d)}"
+EXTRA_OECONF_append_class-nativesdk = " --target-list=${@get_qemu_target_list(d)}"
+
+do_install_append_class-nativesdk() {
+ ${@bb.utils.contains('PACKAGECONFIG', 'gtk+', 'make_qemu_wrapper', '', d)}
+}
+
+PACKAGECONFIG ??= " \
+ fdt sdl kvm \
+ ${@bb.utils.filter('DISTRO_FEATURES', 'alsa xen', d)} \
+"
+PACKAGECONFIG_class-nativesdk ??= "fdt sdl kvm"