summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pip_21.1.2.bb
diff options
context:
space:
mode:
authorTrevor Gamblin <trevor.gamblin@windriver.com>2021-06-22 14:40:59 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-06-27 08:38:31 +0100
commit2135167ca86ff9d112ef3e71f5320c775d075b6c (patch)
tree4cae1caf9a8c1c27b5f2850403175abbc4359673 /meta/recipes-devtools/python/python3-pip_21.1.2.bb
parent7cf427c970aed618f79be90be04e9b756f142c45 (diff)
downloadopenembedded-core-contrib-2135167ca86ff9d112ef3e71f5320c775d075b6c.tar.gz
python3-pip: upgrade 20.0.2 -> 21.1.2
21.1.2 contains a fix for CVE-2021-3572 (https://github.com/pypa/pip/commit/e46bdda9711392fec0c45c1175bae6db847cb30b) The LICENSE.txt signature changed due to an update to the copyright dates, but the terms are the same. Also update 0001-change-shebang-to-python3.patch to cover all files in pip's src directory, since we need to ensure compatibility. Finally, fix the ordering of the "inherit" and "SRC_URI" lines so that devtool will correctly identify that there is a new version upstream. Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-pip_21.1.2.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pip_21.1.2.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pip_21.1.2.bb b/meta/recipes-devtools/python/python3-pip_21.1.2.bb
new file mode 100644
index 0000000000..7367dfdc21
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pip_21.1.2.bb
@@ -0,0 +1,33 @@
+SUMMARY = "The PyPA recommended tool for installing Python packages"
+HOMEPAGE = "https://pypi.org/project/pip"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c4fa2b50f55649f43060fa04b0919b9b"
+
+DEPENDS += "python3 python3-setuptools-native"
+
+inherit pypi distutils3
+
+SRC_URI += "file://0001-change-shebang-to-python3.patch"
+
+SRC_URI[md5sum] = "a867fd51eacfd5293f5b7e0c2e7867a7"
+SRC_URI[sha256sum] = "eb5df6b9ab0af50fe1098a52fd439b04730b6e066887ff7497357b9ebd19f79b"
+
+do_install_append() {
+ # Install as pip3 and leave pip2 as default
+ rm ${D}/${bindir}/pip
+}
+
+RDEPENDS_${PN} = "\
+ python3-compile \
+ python3-io \
+ python3-html \
+ python3-json \
+ python3-netserver \
+ python3-setuptools \
+ python3-unixadmin \
+ python3-xmlrpc \
+ python3-pickle \
+"
+
+BBCLASSEXTEND = "native nativesdk"