summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/llvm/llvm_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-02-26 23:41:30 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-03-01 11:12:12 +0000
commite093eff9d94c02939ca398d59d66d1b1dbc8a12e (patch)
treefc594204e01227b3de0b6a8aa79c7f87c1d8d470 /meta/recipes-devtools/llvm/llvm_git.bb
parentf437b226aac498240bc1e3a02eb0257a7deeedea (diff)
downloadopenembedded-core-contrib-e093eff9d94c02939ca398d59d66d1b1dbc8a12e.tar.gz
llvm: Fix build with c++17
Fixes /benchmark_register.h:17:30: error: 'numeric_limits' is not a member of 'std' | static const T kmax = std::numeric_limits<T>::max(); | ^~~~~~~~~~~~~~ Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/llvm/llvm_git.bb')
-rw-r--r--meta/recipes-devtools/llvm/llvm_git.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-devtools/llvm/llvm_git.bb b/meta/recipes-devtools/llvm/llvm_git.bb
index 86def0878c..db6694339c 100644
--- a/meta/recipes-devtools/llvm/llvm_git.bb
+++ b/meta/recipes-devtools/llvm/llvm_git.bb
@@ -34,6 +34,7 @@ SRC_URI = "git://github.com/llvm/llvm-project.git;branch=${BRANCH} \
file://0006-llvm-TargetLibraryInfo-Undefine-libc-functions-if-th.patch;striplevel=2 \
file://0007-llvm-allow-env-override-of-exe-path.patch;striplevel=2 \
file://0001-AsmMatcherEmitter-sort-ClassInfo-lists-by-name-as-we.patch;striplevel=2 \
+ file://0001-nfc-Fix-missing-include.patch;striplevel=2 \
"
UPSTREAM_CHECK_GITTAGREGEX = "llvmorg-(?P<pver>\d+(\.\d+)+)"