summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/llvm/llvm_git.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-12-29 10:44:13 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-12-30 23:38:12 +0000
commit312e9fe3f047547df4c21c8e666cc9aa70e15347 (patch)
treede6fdd6e8bd855ba97bc8b0266985ee9778da3b4 /meta/recipes-devtools/llvm/llvm_git.bb
parent8413dede13efa8950b0135e09ae104a38c36649c (diff)
downloadopenembedded-core-contrib-312e9fe3f047547df4c21c8e666cc9aa70e15347.tar.gz
recipes: Use -fcommon explicitly
This is needed with gcc 10 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/llvm/llvm_git.bb')
-rw-r--r--meta/recipes-devtools/llvm/llvm_git.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-devtools/llvm/llvm_git.bb b/meta/recipes-devtools/llvm/llvm_git.bb
index d24ed761bf..a8607f5008 100644
--- a/meta/recipes-devtools/llvm/llvm_git.bb
+++ b/meta/recipes-devtools/llvm/llvm_git.bb
@@ -92,6 +92,8 @@ EXTRA_OECMAKE_append_class-nativesdk = "\
-DLLVM_CONFIG_PATH=${STAGING_BINDIR_NATIVE}/llvm-config${PV} \
"
+CFLAGS += "-fcommon"
+
do_configure_prepend() {
# Fix paths in llvm-config
sed -i "s|sys::path::parent_path(CurrentPath))\.str()|sys::path::parent_path(sys::path::parent_path(CurrentPath))).str()|g" ${S}/tools/llvm-config/llvm-config.cpp