aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/gcc/gcc-6.4/0054_all_nopie-all-flags.patch
diff options
context:
space:
mode:
authorJuro Bystricky <juro.bystricky@intel.com>2018-02-20 14:10:52 -0800
committerArmin Kuster <akuster808@gmail.com>2018-02-23 18:33:03 -0800
commita85e1799842242b5ff30a571aa99b7dc2b0f7614 (patch)
tree8cf6db5ed4eeae133b8134f9489510235af271d5 /meta/recipes-devtools/gcc/gcc-6.4/0054_all_nopie-all-flags.patch
parent92fbbcf383013c982105c84c2c077d23dc21b335 (diff)
downloadopenembedded-core-contrib-stable/pyro-next.tar.gz
gcc6: Upgrade to 6.4.1stable/pyro-next
Removed "ubsan-fix-check-empty-string.patch": already upstreamed. Modified "0010-gcc-poison-system-directories.patch" to apply. Removed "0011-gcc-poison-dir-extend.patch" does not apply. Equivalent changes already in "0010-gcc-poison-system-directories.patch" Removed "0055-unwind_h-glibc26.patch": already upstreamed. Modified "CVE-2016-6131.patch" to apply (incompatible ChangeLog patching removed). Signed-off-by: Juro Bystricky <juro.bystricky@intel.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta/recipes-devtools/gcc/gcc-6.4/0054_all_nopie-all-flags.patch')
-rw-r--r--meta/recipes-devtools/gcc/gcc-6.4/0054_all_nopie-all-flags.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-devtools/gcc/gcc-6.4/0054_all_nopie-all-flags.patch b/meta/recipes-devtools/gcc/gcc-6.4/0054_all_nopie-all-flags.patch
new file mode 100644
index 0000000000..73ab9502dc
--- /dev/null
+++ b/meta/recipes-devtools/gcc/gcc-6.4/0054_all_nopie-all-flags.patch
@@ -0,0 +1,22 @@
+Need to pass NO_PIE_CFLAGS to ALL_* so gcc doesn't fail when
+we compile it with older gcc and pie.
+
+Upstream-Status: Inappropriate [configuration]
+
+Maintained by: Gentoo Toolchain Project <toolchain@gentoo.org>
+Signed-off-by: Stephen Arnold <stephen.arnold42@gmail.com>
+
+--- a/gcc/Makefile.in 2015-06-25 19:18:12.000000000 +0200
++++ b/gcc/Makefile.in 2016-04-22 00:12:54.029178860 +0200
+@@ -991,10 +991,10 @@ ALL_CXXFLAGS = $(T_CFLAGS) $(CFLAGS-$@)
+ ALL_CPPFLAGS = $(INCLUDES) $(CPPFLAGS)
+
+ # This is the variable to use when using $(COMPILER).
+-ALL_COMPILERFLAGS = $(ALL_CXXFLAGS)
++ALL_COMPILERFLAGS = $(NO_PIE_CFLAGS) $(ALL_CXXFLAGS)
+
+ # This is the variable to use when using $(LINKER).
+-ALL_LINKERFLAGS = $(ALL_CXXFLAGS)
++ALL_LINKERFLAGS = $(NO_PIE_CFLAGS) $(ALL_CXXFLAGS)
+
+ # Build and host support libraries.