summaryrefslogtreecommitdiffstats
path: root/meta/recipes-core
diff options
context:
space:
mode:
authorQiu Tingting <qiutt@fujitsu.com>2023-09-26 08:12:31 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-09-28 12:37:44 +0100
commit12eed1e6c701759321541d2c04eeca3db3c99247 (patch)
treeaba3fade2237acee0aa5003b103d3ac614abf4d0 /meta/recipes-core
parent03a90095f5c1977a78f1a4ce568b793ebabfb281 (diff)
downloadopenembedded-core-contrib-12eed1e6c701759321541d2c04eeca3db3c99247.tar.gz
tar: add ptest support
Add a ptest for tar. - It is taking around 3m to execute with kvm, so added it to PTEST_SLOW. - It contains 244 cases. - Below is parts of the run log: START: ptest-runner 2023-09-26T08:37 BEGIN: /usr/lib/tar/ptest ## ------------------------ ## ## GNU tar 1.35 test suite. ## ## ------------------------ ## PASS: tar version PASS: decompressing from stdin ... 200 tests were successful. 44 tests were skipped. DURATION: 190 END: /usr/lib/tar/ptest 2023-09-26T08:40 STOP: ptest-runner TOTAL: 1 FAIL: 0 Signed-off-by: Qiu Tingting <qiutt@fujitsu.com> Signed-off-by: Yan Xinkuan <yanxk.fnst@fujitsu.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
Diffstat (limited to 'meta/recipes-core')
-rw-r--r--meta/recipes-core/images/core-image-ptest.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-core/images/core-image-ptest.bb b/meta/recipes-core/images/core-image-ptest.bb
index b81ab7b7c8..b6f5c2fd60 100644
--- a/meta/recipes-core/images/core-image-ptest.bb
+++ b/meta/recipes-core/images/core-image-ptest.bb
@@ -24,6 +24,9 @@ IMAGE_ROOTFS_EXTRA_SPACE:virtclass-mcextend-mdadm = "1524288"
IMAGE_ROOTFS_EXTRA_SPACE:virtclass-mcextend-strace = "1024288"
IMAGE_ROOTFS_EXTRA_SPACE:virtclass-mcextend-lttng-tools = "1524288"
+# tar-ptest in particular needs more space
+IMAGE_ROOTFS_EXTRA_SPACE:virtclass-mcextend-tar = "1524288"
+
# ptests need more memory than standard to avoid the OOM killer
QB_MEM = "-m 1024"
QB_MEM:virtclass-mcextend-lttng-tools = "-m 4096"