summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <tim.orling@konsulko.com>2022-03-12 12:46:44 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-03-16 08:44:45 +0000
commit8eaafc114c196fbab2070bfb600634306deef527 (patch)
treedabae8e34ebcaacbd87863a3e4b0c104a205962a
parentc0ba17345282509211bb1f11d7184d131204411d (diff)
downloadopenembedded-core-contrib-8eaafc114c196fbab2070bfb600634306deef527.tar.gz
python3-setuptools-rust-native: from meta-python
Dependency for python3-cryptography 3.4.x+ Only native rustc is supported at this time in oe-core, therefore it makes no sense to try to build for target. Signed-off-by: Tim Orling <tim.orling@konsulko.com>
-rw-r--r--meta/recipes-devtools/python/python3-setuptools-rust-native_1.1.2.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-setuptools-rust-native_1.1.2.bb b/meta/recipes-devtools/python/python3-setuptools-rust-native_1.1.2.bb
new file mode 100644
index 0000000000..73dcbb26e6
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-setuptools-rust-native_1.1.2.bb
@@ -0,0 +1,33 @@
+SUMMARY = "Setuptools Rust extension plugin"
+DESCRIPTION = "setuptools-rust is a plugin for setuptools to build Rust \
+Python extensions implemented with PyO3 or rust-cpython.\
+\
+Compile and distribute Python extensions written in Rust as easily as if they were written in C."
+HOMEPAGE = "https://github.com/PyO3/setuptools-rust"
+BUGTRACKER = "https://github.com/PyO3/setuptools-rust/issues"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=011cd92e702dd9e6b1a26157b6fd53f5"
+
+SRC_URI = "https://files.pythonhosted.org/packages/67/08/e1aa2c582c62ac76e4d60f8e454bd3bba933781a06a88b4e38797445822a/setuptools-rust-${PV}.tar.gz"
+SRC_URI[sha256sum] = "a0adb9b503c0ffc4e8fe80b7c617898cefa78049983aaaea7f747e153a3e65d1"
+
+# While this has a pyproject.toml and declares that setuptools_build_meta should work
+# it results in a wheel named UNKNOWN-0.0.0-py3-none-any.whl so stay with setuptools3
+# until that can be resolved
+inherit cargo pypi setuptools3 native
+
+# For some reason the wheel is built in ${S} not ${B}
+PIP_INSTALL_DIST_PATH = "${S}/dist"
+PIP_INSTALL_PACKAGE = "setuptools_rust"
+
+DEPENDS += "python3-setuptools-scm-native python3-wheel-native"
+
+RDEPENDS:${PN}:class-native += " \
+ python3-semantic-version-native \
+ python3-setuptools-native \
+ python3-setuptools-scm-native \
+ python3-toml-native \
+ python3-typing-extensions-native \
+ python3-wheel-native \
+"