aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-native_2.7.18.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/python/python-native_2.7.18.bb')
-rw-r--r--recipes-devtools/python/python-native_2.7.18.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-devtools/python/python-native_2.7.18.bb b/recipes-devtools/python/python-native_2.7.18.bb
index 5b29c9f..95a8a86 100644
--- a/recipes-devtools/python/python-native_2.7.18.bb
+++ b/recipes-devtools/python/python-native_2.7.18.bb
@@ -23,7 +23,7 @@ FILESEXTRAPATHS =. "${FILE_DIRNAME}/${PN}:"
inherit native
-EXTRA_OECONF_append = " --bindir=${bindir}/${PN} --with-system-expat=${STAGING_DIR_HOST}"
+EXTRA_OECONF:append = " --bindir=${bindir}/${PN} --with-system-expat=${STAGING_DIR_HOST}"
EXTRA_OEMAKE = '\
LIBC="" \
@@ -31,12 +31,12 @@ EXTRA_OEMAKE = '\
STAGING_INCDIR=${STAGING_INCDIR_NATIVE} \
'
-do_configure_append() {
+do_configure:append() {
autoreconf --verbose --install --force --exclude=autopoint ../Python-${PV}/Modules/_ctypes/libffi
}
# Cross-compiling Python needs a native pgen, build it here for use later.
-do_compile_append() {
+do_compile:append() {
oe_runmake Parser/pgen
}