aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python.inc
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-07-29 17:06:40 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2021-08-03 13:36:54 +0200
commit4626bb642da57bc981f193dea8f5e0b6518b7b1c (patch)
treef1584ac985c452f151d79b94a7be7180c195a0d6 /recipes-devtools/python/python.inc
parent8db9e4f6ceae33d7a4f55453d31e69f9858af4eb (diff)
downloadmeta-python2-4626bb642da57bc981f193dea8f5e0b6518b7b1c.tar.gz
Convert to new override syntax
This is the result of automated script (0.9.0) conversion: oe-core/scripts/contrib/convert-overrides.py . converting the metadata to use ":" as the override character instead of "_". Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python.inc')
-rw-r--r--recipes-devtools/python/python.inc4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-devtools/python/python.inc b/recipes-devtools/python/python.inc
index dc5807a..7325f8c 100644
--- a/recipes-devtools/python/python.inc
+++ b/recipes-devtools/python/python.inc
@@ -47,13 +47,13 @@ EXTRA_OECONF = "\
ac_cv_header_bluetooth_bluetooth_h=no ac_cv_header_bluetooth_h=no \
"
-do_configure_prepend() {
+do_configure:prepend() {
libdirleaf="$(echo ${libdir} | sed -e 's:${prefix}/::')"
sed -i -e "s:SEDMELIBLEAF:${libdirleaf}:g" \
${S}/configure.ac
}
-do_install_append () {
+do_install:append () {
sed -i -e 's:${HOSTTOOLS_DIR}/install:install:g' \
-e 's:${HOSTTOOLS_DIR}/mkdir:mkdir:g' \
${D}/${libdir}/python${PYTHON_MAJMIN}/_sysconfigdata.py