aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-zopeinterface_4.7.1.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-07-29 17:06:40 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2021-08-03 13:36:54 +0200
commit4626bb642da57bc981f193dea8f5e0b6518b7b1c (patch)
treef1584ac985c452f151d79b94a7be7180c195a0d6 /recipes-devtools/python/python-zopeinterface_4.7.1.bb
parent8db9e4f6ceae33d7a4f55453d31e69f9858af4eb (diff)
downloadmeta-python2-4626bb642da57bc981f193dea8f5e0b6518b7b1c.tar.gz
Convert to new override syntax
This is the result of automated script (0.9.0) conversion: oe-core/scripts/contrib/convert-overrides.py . converting the metadata to use ":" as the override character instead of "_". Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-zopeinterface_4.7.1.bb')
-rw-r--r--recipes-devtools/python/python-zopeinterface_4.7.1.bb14
1 files changed, 7 insertions, 7 deletions
diff --git a/recipes-devtools/python/python-zopeinterface_4.7.1.bb b/recipes-devtools/python/python-zopeinterface_4.7.1.bb
index 99c9213..4eefbd6 100644
--- a/recipes-devtools/python/python-zopeinterface_4.7.1.bb
+++ b/recipes-devtools/python/python-zopeinterface_4.7.1.bb
@@ -9,19 +9,19 @@ PYPI_PACKAGE = "zope.interface"
PACKAGES =. "${PN}-test "
-RPROVIDES_${PN} += "zope-interfaces"
+RPROVIDES:${PN} += "zope-interfaces"
-RDEPENDS_${PN}_class-target += "${PYTHON_PN}-datetime"
+RDEPENDS:${PN}:class-target += "${PYTHON_PN}-datetime"
-FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/*.egg/*/*/.debug"
-FILES_${PN}-dev += "${PYTHON_SITEPACKAGES_DIR}/zope/interface/*.c"
-FILES_${PN}-doc += "${PYTHON_SITEPACKAGES_DIR}/zope/interface/*.txt"
-FILES_${PN}-test += " \
+FILES:${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/*.egg/*/*/.debug"
+FILES:${PN}-dev += "${PYTHON_SITEPACKAGES_DIR}/zope/interface/*.c"
+FILES:${PN}-doc += "${PYTHON_SITEPACKAGES_DIR}/zope/interface/*.txt"
+FILES:${PN}-test += " \
${PYTHON_SITEPACKAGES_DIR}/zope/interface/tests \
${PYTHON_SITEPACKAGES_DIR}/zope/interface/common/tests \
"
inherit pypi setuptools
-RDEPENDS_${PN}-test += "python-unittest python-doctest"
+RDEPENDS:${PN}-test += "python-unittest python-doctest"
PNBLACKLIST[python-zopeinterface] ?= "${@bb.utils.contains('I_SWEAR_TO_MIGRATE_TO_PYTHON3', 'yes', '', 'python2 is out of support for long time, read https://www.python.org/doc/sunset-python-2/ https://python3statement.org/ and if you really have to temporarily use this, then set I_SWEAR_TO_MIGRATE_TO_PYTHON3 to "yes"', d)}"