aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-webencodings_0.5.1.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2019-11-26 21:20:53 -0800
committerTim Orling <ticotimo@gmail.com>2019-12-01 17:02:53 -0800
commite361b57cf3d9d6b871d1d165fe455b6ce6075dfb (patch)
tree70d441d87f65d333e22c4b2ecbefd1536e141ccb /recipes-devtools/python/python-webencodings_0.5.1.bb
parent0eb37ac4435f3a5f6730a9312b731059ed7e8797 (diff)
downloadmeta-python2-e361b57cf3d9d6b871d1d165fe455b6ce6075dfb.tar.gz
recipes-devtools: merge inc and bb PART I
Since we no longer need to support two python versions, merge inc and bb. This makes maintenance easier with AUH and devtool. While we are at it, drop some dangling inc files and some python3 recipes. Enforce Debian naming (python-foo). Only recipes that are executable tools, such as 'gyp' or 'gateone' should be exceptions. When in doubt, search for what the package is named in Debian or Fedora. Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-webencodings_0.5.1.bb')
-rw-r--r--recipes-devtools/python/python-webencodings_0.5.1.bb17
1 files changed, 15 insertions, 2 deletions
diff --git a/recipes-devtools/python/python-webencodings_0.5.1.bb b/recipes-devtools/python/python-webencodings_0.5.1.bb
index 5de2ed1..0851853 100644
--- a/recipes-devtools/python/python-webencodings_0.5.1.bb
+++ b/recipes-devtools/python/python-webencodings_0.5.1.bb
@@ -1,2 +1,15 @@
-inherit setuptools
-require python-webencodings.inc
+SUMMARY = "Character encoding aliases for legacy web content"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=e910b35b0ef4e1f665b9a75d6afb7709"
+
+SRC_URI[md5sum] = "32f6e261d52e57bf7e1c4d41546d15b8"
+SRC_URI[sha256sum] = "b36a1c245f2d304965eb4e0a82848379241dc04b865afcc4aab16748587e1923"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-codecs \
+ ${PYTHON_PN}-json \
+"
+
+BBCLASSEXTEND = "native nativesdk"