aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-redis_2.10.6.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2019-11-27 07:36:38 -0800
committerTim Orling <ticotimo@gmail.com>2019-12-01 17:03:31 -0800
commit0890fb548d98199da117816b33fdbbf5c6c83547 (patch)
tree6128f33298798f3d12aace67963e355e243d7483 /recipes-devtools/python/python-redis_2.10.6.bb
parent9d6cfe3284388c2e34430680d585891e58259ea8 (diff)
downloadmeta-python2-0890fb548d98199da117816b33fdbbf5c6c83547.tar.gz
recipes-devtools: merge inc and bb PART III
Since we no longer need to support two python versions, merge inc and bb. This makes maintenance easier with AUH and devtool. While we are at it, drop dangling inc files and general recipe cleanup, including adding SUMMARY and HOMEPAGE. Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-redis_2.10.6.bb')
-rw-r--r--recipes-devtools/python/python-redis_2.10.6.bb15
1 files changed, 14 insertions, 1 deletions
diff --git a/recipes-devtools/python/python-redis_2.10.6.bb b/recipes-devtools/python/python-redis_2.10.6.bb
index 6c3ca85..4b6ff93 100644
--- a/recipes-devtools/python/python-redis_2.10.6.bb
+++ b/recipes-devtools/python/python-redis_2.10.6.bb
@@ -1,2 +1,15 @@
+
+SUMMARY = "Python client for Redis key-value store"
+DESCRIPTION = "The Python interface to the Redis key-value store."
+HOMEPAGE = "http://github.com/andymccurdy/redis-py"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=51d9ad56299ab60ba7be65a621004f27"
+
+SRC_URI[md5sum] = "048348d8cfe0b5d0bba2f4d835005c3b"
+SRC_URI[sha256sum] = "a22ca993cea2962dbb588f9f30d0015ac4afcc45bee27d3978c0dbe9e97c6c0f"
+
inherit pypi setuptools
-require python-redis.inc
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-datetime \
+"