aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-pysqlite_2.8.3.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2019-11-27 07:36:38 -0800
committerTim Orling <ticotimo@gmail.com>2019-12-01 17:03:31 -0800
commit0890fb548d98199da117816b33fdbbf5c6c83547 (patch)
tree6128f33298798f3d12aace67963e355e243d7483 /recipes-devtools/python/python-pysqlite_2.8.3.bb
parent9d6cfe3284388c2e34430680d585891e58259ea8 (diff)
downloadmeta-python2-0890fb548d98199da117816b33fdbbf5c6c83547.tar.gz
recipes-devtools: merge inc and bb PART III
Since we no longer need to support two python versions, merge inc and bb. This makes maintenance easier with AUH and devtool. While we are at it, drop dangling inc files and general recipe cleanup, including adding SUMMARY and HOMEPAGE. Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-pysqlite_2.8.3.bb')
-rw-r--r--recipes-devtools/python/python-pysqlite_2.8.3.bb23
1 files changed, 21 insertions, 2 deletions
diff --git a/recipes-devtools/python/python-pysqlite_2.8.3.bb b/recipes-devtools/python/python-pysqlite_2.8.3.bb
index 95938f2..ec8cec4 100644
--- a/recipes-devtools/python/python-pysqlite_2.8.3.bb
+++ b/recipes-devtools/python/python-pysqlite_2.8.3.bb
@@ -1,2 +1,21 @@
-inherit setuptools
-require python-pysqlite.inc
+SUMMARY = "DB-API 2.0 interface for SQLite 3.x"
+DESCRIPTION = "pysqlite is an interface to the SQLite 3.x embedded relational \
+database engine. It is almost fully compliant with the Python database API \
+version 2.0 also exposes the unique features of SQLite."
+HOMEPAGE = "http://github.com/ghaering/pysqlite"
+LICENSE = "Zlib"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=28ad4f115e06c88bd737372a453369d8"
+
+SRC_URI[md5sum] = "033f17b8644577715aee55e8832ac9fc"
+SRC_URI[sha256sum] = "17d3335863e8cf8392eea71add33dab3f96d060666fe68ab7382469d307f4490"
+
+inherit pypi setuptools
+
+DEPENDS += "${PYTHON_PN}-pip"
+
+RDEPENDS_${PN}_class-target += "\
+ ${PYTHON_PN}-datetime \
+ sqlite3 \
+"
+
+FILES_${PN}-doc += "${datadir}"