aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-pyperclip_1.7.0.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2019-11-27 07:36:38 -0800
committerTim Orling <ticotimo@gmail.com>2019-12-01 17:03:31 -0800
commit0890fb548d98199da117816b33fdbbf5c6c83547 (patch)
tree6128f33298798f3d12aace67963e355e243d7483 /recipes-devtools/python/python-pyperclip_1.7.0.bb
parent9d6cfe3284388c2e34430680d585891e58259ea8 (diff)
downloadmeta-python2-0890fb548d98199da117816b33fdbbf5c6c83547.tar.gz
recipes-devtools: merge inc and bb PART III
Since we no longer need to support two python versions, merge inc and bb. This makes maintenance easier with AUH and devtool. While we are at it, drop dangling inc files and general recipe cleanup, including adding SUMMARY and HOMEPAGE. Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-pyperclip_1.7.0.bb')
-rw-r--r--recipes-devtools/python/python-pyperclip_1.7.0.bb16
1 files changed, 14 insertions, 2 deletions
diff --git a/recipes-devtools/python/python-pyperclip_1.7.0.bb b/recipes-devtools/python/python-pyperclip_1.7.0.bb
index 6c9fcbd..0df824b 100644
--- a/recipes-devtools/python/python-pyperclip_1.7.0.bb
+++ b/recipes-devtools/python/python-pyperclip_1.7.0.bb
@@ -1,7 +1,19 @@
-inherit setuptools
-require python-pyperclip.inc
+SUMMARY = "A cross-platform clipboard module for Python."
+DESCRIPTION = "Pyperclip is a cross-platform Python module for copy and paste \
+clipboard functions (only handles plain text for now)."
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=a428356ada7737b416ec4b63dc65d581"
+
+SRC_URI[md5sum] = "6bbb8598579cc3ee50554b4c59d0cfae"
+SRC_URI[sha256sum] = "979325468ccf682104d5dcaf753f869868100631301d3e72f47babdea5700d1c"
+
+inherit pypi setuptools
RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-ctypes \
${PYTHON_PN}-contextlib \
${PYTHON_PN}-subprocess \
"
+
+BBCLASSEXTEND = "native nativesdk"
+