aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-pybluez_0.22.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2019-11-27 20:37:45 -0800
committerTim Orling <ticotimo@gmail.com>2019-12-01 17:03:50 -0800
commitda918f657c32ff9a5b5d9969604a2e255af473ec (patch)
tree69bbc29f7780e7a7853bf94de9abe3666db77cdd /recipes-devtools/python/python-pybluez_0.22.bb
parent0890fb548d98199da117816b33fdbbf5c6c83547 (diff)
downloadmeta-python2-da918f657c32ff9a5b5d9969604a2e255af473ec.tar.gz
recipes-devtools: merge inc and bb PART IV
Since we no longer need to support two python versions, merge inc and bb. This makes maintenance easier with AUH and devtool. While we are at it, drop dangling inc files and general recipe cleanup, including adding SUMMARY and HOMEPAGE. Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-pybluez_0.22.bb')
-rw-r--r--recipes-devtools/python/python-pybluez_0.22.bb27
1 files changed, 25 insertions, 2 deletions
diff --git a/recipes-devtools/python/python-pybluez_0.22.bb b/recipes-devtools/python/python-pybluez_0.22.bb
index 3158f4b..4da2292 100644
--- a/recipes-devtools/python/python-pybluez_0.22.bb
+++ b/recipes-devtools/python/python-pybluez_0.22.bb
@@ -1,2 +1,25 @@
-require python-pybluez.inc
-inherit setuptools
+
+SUMMARY = "Bluetooth Python extension module"
+DESCRIPTION = "Bluetooth Python extension module"
+HOMEPAGE = "https://pybluez.readthedocs.io/"
+SECTION = "devel/python"
+
+DEPENDS = "bluez5"
+
+LICENSE = "GPL-2.0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=8a71d0475d08eee76d8b6d0c6dbec543"
+
+SRC_URI[md5sum] = "49dab9d5a8f0b798c8125c7f649be3cd"
+SRC_URI[sha256sum] = "4ce006716a54d9d18e8186a3f1c8b12a8e6befecffe8fd5828a291fb694ce49d"
+
+S = "${WORKDIR}/PyBluez-${PV}"
+
+PYPI_PACKAGE = "PyBluez"
+PYPI_PACKAGE_EXT = "zip"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN} += "\
+ bluez5 \
+ ${PYTHON_PN}-fcntl \
+"