aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-lockfile_0.12.2.bb
diff options
context:
space:
mode:
authorleimaohui <leimaohui@cn.fujitsu.com>2018-05-19 14:43:08 -0700
committerKhem Raj <raj.khem@gmail.com>2018-05-29 12:57:23 -0700
commit25aad6e417598f404f568efab247a36926b66617 (patch)
treea035840a08aa8407656ec87e534f317cea9b1fd2 /recipes-devtools/python/python-lockfile_0.12.2.bb
parenta0b157638a2d90463713cafac4b0341ecc9e784b (diff)
downloadmeta-python2-25aad6e417598f404f568efab247a36926b66617.tar.gz
python-lockfile: Fix build error as following:
"distutils.errors.DistutilsError: Could not find suitable distribution for Requirement.parse('pbr>=1.8')" (From meta-openembedded commit: 75540ab1499ca9e4a2cd890012cda56620fc5a54) Signed-off-by: Lei Maohui <leimaohui@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-lockfile_0.12.2.bb')
-rw-r--r--recipes-devtools/python/python-lockfile_0.12.2.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-lockfile_0.12.2.bb b/recipes-devtools/python/python-lockfile_0.12.2.bb
index cd15760..9ad865d 100644
--- a/recipes-devtools/python/python-lockfile_0.12.2.bb
+++ b/recipes-devtools/python/python-lockfile_0.12.2.bb
@@ -11,3 +11,9 @@ inherit pypi setuptools
SRC_URI[md5sum] = "a6a1a82957a23afdf44cfdd039b65ff9"
SRC_URI[sha256sum] = "6aed02de03cba24efabcd600b30540140634fc06cfa603822d508d5361e9f799"
+
+# Satisfy setup.py 'setup_requires'
+DEPENDS += " \
+ python-pbr-native \
+ "
+