aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-incremental_17.5.0.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2019-11-27 21:32:09 -0800
committerTim Orling <ticotimo@gmail.com>2019-12-01 17:04:08 -0800
commitcbb37ae16a84c38c5be6b34f7ec8f30a8e9f52af (patch)
tree08959adf4d3ae8854cb39af6dab9851533659522 /recipes-devtools/python/python-incremental_17.5.0.bb
parentda918f657c32ff9a5b5d9969604a2e255af473ec (diff)
downloadmeta-python2-cbb37ae16a84c38c5be6b34f7ec8f30a8e9f52af.tar.gz
recipes-devtools: merge inc and bb PART V
Since we no longer need to support two python versions, merge inc and bb. This makes maintenance easier with AUH and devtool. While we are at it, drop dangling inc files and general recipe cleanup, including adding SUMMARY and HOMEPAGE. Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-incremental_17.5.0.bb')
-rw-r--r--recipes-devtools/python/python-incremental_17.5.0.bb22
1 files changed, 20 insertions, 2 deletions
diff --git a/recipes-devtools/python/python-incremental_17.5.0.bb b/recipes-devtools/python/python-incremental_17.5.0.bb
index 139ac0c..c02c58a 100644
--- a/recipes-devtools/python/python-incremental_17.5.0.bb
+++ b/recipes-devtools/python/python-incremental_17.5.0.bb
@@ -1,2 +1,20 @@
-inherit setuptools
-require python-incremental.inc
+DESCRIPTION = "Incremental is a small library that versions your Python projects"
+HOMEPAGE = "https://github.com/twisted/incremental"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=6ca9b07f08e2c72d48c74d363d1e0e15"
+
+SRC_URI[md5sum] = "602746e0d438e075a5a9e0678140bba2"
+SRC_URI[sha256sum] = "7b751696aaf36eebfab537e458929e194460051ccad279c72b755a167eebd4b3"
+
+inherit pypi setuptools
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-twisted \
+ ${PYTHON_PN}-click \
+"
+
+# -native is needed to build python[3]-twisted, however, we need to take steps to
+# prevent a circular dependency. The build apparently does not use the part of
+# python-incremental which uses python-twisted, so this hack is OK.
+RDEPENDS_${PYTHON_PN}-incremental-native_remove = "${PYTHON_PN}-twisted-native"
+BBCLASSEXTEND = "native"