aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-gevent_1.4.0.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-07-29 17:06:40 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2021-08-03 13:36:54 +0200
commit4626bb642da57bc981f193dea8f5e0b6518b7b1c (patch)
treef1584ac985c452f151d79b94a7be7180c195a0d6 /recipes-devtools/python/python-gevent_1.4.0.bb
parent8db9e4f6ceae33d7a4f55453d31e69f9858af4eb (diff)
downloadmeta-python2-4626bb642da57bc981f193dea8f5e0b6518b7b1c.tar.gz
Convert to new override syntax
This is the result of automated script (0.9.0) conversion: oe-core/scripts/contrib/convert-overrides.py . converting the metadata to use ":" as the override character instead of "_". Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-gevent_1.4.0.bb')
-rw-r--r--recipes-devtools/python/python-gevent_1.4.0.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/recipes-devtools/python/python-gevent_1.4.0.bb b/recipes-devtools/python/python-gevent_1.4.0.bb
index d7d3886..28fc516 100644
--- a/recipes-devtools/python/python-gevent_1.4.0.bb
+++ b/recipes-devtools/python/python-gevent_1.4.0.bb
@@ -13,9 +13,9 @@ SRC_URI[sha256sum] = "1eb7fa3b9bd9174dfe9c3b59b7a09b768ecd496debfc4976a9530a3e15
DEPENDS += "libevent ${PYTHON_PN}-greenlet"
-FILESEXTRAPATHS_prepend := "${THISDIR}/python-gevent:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/python-gevent:"
-SRC_URI_append = " \
+SRC_URI:append = " \
file://libev-conf.patch;patch=1;pnum=1 \
file://0002-setup.py-do-not-query-for-include-dir.patch \
"
@@ -23,7 +23,7 @@ SRC_URI_append = " \
inherit pypi setuptools
-RDEPENDS_${PN} = "\
+RDEPENDS:${PN} = "\
${PYTHON_PN}-greenlet \
${PYTHON_PN}-mime \
${PYTHON_PN}-pprint \
@@ -33,7 +33,7 @@ RDEPENDS_${PN} = "\
# The python-gevent has no autoreconf ability
# and the logic for detecting a cross compile is flawed
# so always force a cross compile
-do_configure_append() {
+do_configure:append() {
sed -i -e 's/^cross_compiling=no/cross_compiling=yes/' ${S}/deps/libev/configure
sed -i -e 's/^cross_compiling=no/cross_compiling=yes/' ${S}/deps/c-ares/configure
}