aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-coloredlogs_10.0.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2019-11-29 16:30:46 -0800
committerTim Orling <ticotimo@gmail.com>2019-12-01 17:04:25 -0800
commit3a336d8f08b3f597807d3158077d0e1c830c75ed (patch)
tree133756c00c77a7d2062a29e7309970193d7cfde2 /recipes-devtools/python/python-coloredlogs_10.0.bb
parentcbb37ae16a84c38c5be6b34f7ec8f30a8e9f52af (diff)
downloadmeta-python2-3a336d8f08b3f597807d3158077d0e1c830c75ed.tar.gz
recipes-devtools: merge inc and bb PART VI
Since we no longer need to support two python versions, merge inc and bb. This makes maintenance easier with AUH and devtool. While we are at it, drop dangling inc files and general recipe cleanup, including adding SUMMARY and HOMEPAGE. Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-coloredlogs_10.0.bb')
-rw-r--r--recipes-devtools/python/python-coloredlogs_10.0.bb34
1 files changed, 32 insertions, 2 deletions
diff --git a/recipes-devtools/python/python-coloredlogs_10.0.bb b/recipes-devtools/python/python-coloredlogs_10.0.bb
index 0fc1b25..5a5e4d4 100644
--- a/recipes-devtools/python/python-coloredlogs_10.0.bb
+++ b/recipes-devtools/python/python-coloredlogs_10.0.bb
@@ -1,2 +1,32 @@
-inherit setuptools
-require python-coloredlogs.inc
+SUMMARY = "Colored terminal output for Python's logging module"
+DESCRIPTION = "The coloredlogs package enables colored terminal output for \
+Python’s logging module. The ColoredFormatter class inherits from \
+logging.Formatter and uses ANSI escape sequences to render your logging \
+messages in color. It uses only standard colors so it should work on any UNIX \
+terminal. It’s currently tested on Python 2.6, 2.7, 3.4, 3.5, 3.6 and PyPy. On \
+Windows coloredlogs automatically pulls in Colorama as a dependency and \
+enables ANSI escape sequence translation using Colorama."
+HOMEPAGE = "https://coloredlogs.readthedocs.io"
+SECTION = "devel/python"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=690da298a43805797a4fa7bbe180b3c6"
+
+SRC_URI[md5sum] = "0a186966a1955fff8cf9489373e691d9"
+SRC_URI[sha256sum] = "b869a2dda3fa88154b9dd850e27828d8755bfab5a838a1c97fbc850c6e377c36"
+
+inherit pypi setuptools
+
+do_compile_prepend() {
+ sed -ie "s/find_pth_directory(),/'',/g" setup.py
+}
+
+do_install_append() {
+ rm -rf ${D}${datadir}
+}
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-humanfriendly \
+"
+
+BBCLASSEXTEND = "native"