aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-babel_2.7.0.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2019-11-29 16:30:46 -0800
committerTim Orling <ticotimo@gmail.com>2019-12-01 17:04:25 -0800
commit3a336d8f08b3f597807d3158077d0e1c830c75ed (patch)
tree133756c00c77a7d2062a29e7309970193d7cfde2 /recipes-devtools/python/python-babel_2.7.0.bb
parentcbb37ae16a84c38c5be6b34f7ec8f30a8e9f52af (diff)
downloadmeta-python2-3a336d8f08b3f597807d3158077d0e1c830c75ed.tar.gz
recipes-devtools: merge inc and bb PART VI
Since we no longer need to support two python versions, merge inc and bb. This makes maintenance easier with AUH and devtool. While we are at it, drop dangling inc files and general recipe cleanup, including adding SUMMARY and HOMEPAGE. Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-babel_2.7.0.bb')
-rw-r--r--recipes-devtools/python/python-babel_2.7.0.bb29
1 files changed, 27 insertions, 2 deletions
diff --git a/recipes-devtools/python/python-babel_2.7.0.bb b/recipes-devtools/python/python-babel_2.7.0.bb
index f7c166e..dba0054 100644
--- a/recipes-devtools/python/python-babel_2.7.0.bb
+++ b/recipes-devtools/python/python-babel_2.7.0.bb
@@ -1,6 +1,31 @@
-inherit setuptools
-require python-babel.inc
+SUMMARY = "Internationalization utilities"
+DESCRIPTION = "A collection of tools for internationalizing Python applications"
+HOMEPAGE = "http://babel.edgewall.org/"
+SECTION = "devel/python"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=942469df9305abb1c59e95f778310384"
+
+SRC_URI[md5sum] = "83c158b7dae9135750a7cf204e6e2eea"
+SRC_URI[sha256sum] = "e86135ae101e31e2c8ec20a4e0c5220f4eed12487d5cf3f78be7e98d3a57fc28"
+
+PYPI_PACKAGE = "Babel"
+
+inherit pypi setuptools
+
+CLEANBROKEN = "1"
RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-codecs \
+ ${PYTHON_PN}-difflib \
+ ${PYTHON_PN}-distutils \
+ ${PYTHON_PN}-netserver \
+ ${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-pickle \
+ ${PYTHON_PN}-pytz \
+ ${PYTHON_PN}-shell \
${PYTHON_PN}-subprocess \
+ ${PYTHON_PN}-threading \
"
+
+BBCLASSEXTEND = "native nativesdk"