aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/python/python-attr_0.3.1.bb
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2019-11-29 16:30:46 -0800
committerTim Orling <ticotimo@gmail.com>2019-12-01 17:04:25 -0800
commit3a336d8f08b3f597807d3158077d0e1c830c75ed (patch)
tree133756c00c77a7d2062a29e7309970193d7cfde2 /recipes-devtools/python/python-attr_0.3.1.bb
parentcbb37ae16a84c38c5be6b34f7ec8f30a8e9f52af (diff)
downloadmeta-python2-3a336d8f08b3f597807d3158077d0e1c830c75ed.tar.gz
recipes-devtools: merge inc and bb PART VI
Since we no longer need to support two python versions, merge inc and bb. This makes maintenance easier with AUH and devtool. While we are at it, drop dangling inc files and general recipe cleanup, including adding SUMMARY and HOMEPAGE. Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-devtools/python/python-attr_0.3.1.bb')
-rw-r--r--recipes-devtools/python/python-attr_0.3.1.bb14
1 files changed, 12 insertions, 2 deletions
diff --git a/recipes-devtools/python/python-attr_0.3.1.bb b/recipes-devtools/python/python-attr_0.3.1.bb
index 979d6cb..88edf13 100644
--- a/recipes-devtools/python/python-attr_0.3.1.bb
+++ b/recipes-devtools/python/python-attr_0.3.1.bb
@@ -1,2 +1,12 @@
-inherit setuptools
-require python-attr.inc
+SUMMARY = "Simple decorator to set attributes of target function or class in a DRY way"
+DESCRIPTION = "Simple decorator to set attributes of target function or class in a DRY way"
+HOMEPAGE = "https://github.com/denis-ryzhkov/attr"
+SECTION = "devel/python"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=59805a0285f4d2b6abdedae73db4f5c1"
+
+SRC_URI[md5sum] = "68b9a503991241fb2df28488686b0e1e"
+SRC_URI[sha256sum] = "9091548058d17f132596e61fa7518e504f76b9a4c61ca7d86e1f96dbf7d4775d"
+
+inherit pypi setuptools