aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-connectivity/python-mprpc
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2019-11-26 20:28:39 -0800
committerTim Orling <ticotimo@gmail.com>2019-12-01 17:02:53 -0800
commit0eb37ac4435f3a5f6730a9312b731059ed7e8797 (patch)
tree4cfe5d9e2678d32e48e0d0d2515f05be2f0321dc /recipes-connectivity/python-mprpc
parente4798b3c6a5782c9047305038715bd8451bf224f (diff)
downloadmeta-python2-0eb37ac4435f3a5f6730a9312b731059ed7e8797.tar.gz
recipes-connectivity: merge inc and bb
Since we no longer need to support two python versions, merge inc and bb. This makes maintenance easier wih AUH and devtool. Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'recipes-connectivity/python-mprpc')
-rw-r--r--recipes-connectivity/python-mprpc/python-mprpc.inc13
-rw-r--r--recipes-connectivity/python-mprpc/python-mprpc_0.1.17.bb16
2 files changed, 14 insertions, 15 deletions
diff --git a/recipes-connectivity/python-mprpc/python-mprpc.inc b/recipes-connectivity/python-mprpc/python-mprpc.inc
deleted file mode 100644
index e9eebe8..0000000
--- a/recipes-connectivity/python-mprpc/python-mprpc.inc
+++ /dev/null
@@ -1,13 +0,0 @@
-SUMMARY = "A gevent based messagpack rpc library"
-DESCRIPTION = "mprpc is a fast implementation of the messagepack rpc protocol for python. \
-It is based on gevent for handling connections and enabling concurrent connections."
-HOMEPAGE = "https://github.com/studio-ousia/mprpc"
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=4ba825394aec026b5f94edca44426859"
-DEPENDS += "${PYTHON_PN}-gevent"
-RDEPENDS_${PN} += "${PYTHON_PN}-gevent ${PYTHON_PN}-msgpack ${PYTHON_PN}-gsocketpool"
-
-SRC_URI[md5sum] = "8d97961051422f3de315613434982d3b"
-SRC_URI[sha256sum] = "3589fd127482e291b1ec314d6f0e55cc13311c12932ace356d6178ea1ca28f6a"
-
-inherit pypi
diff --git a/recipes-connectivity/python-mprpc/python-mprpc_0.1.17.bb b/recipes-connectivity/python-mprpc/python-mprpc_0.1.17.bb
index 6b2ea21..62cafa8 100644
--- a/recipes-connectivity/python-mprpc/python-mprpc_0.1.17.bb
+++ b/recipes-connectivity/python-mprpc/python-mprpc_0.1.17.bb
@@ -1,2 +1,14 @@
-require python-mprpc.inc
-inherit setuptools
+SUMMARY = "A gevent based messagpack rpc library"
+DESCRIPTION = "mprpc is a fast implementation of the messagepack rpc protocol for python. \
+It is based on gevent for handling connections and enabling concurrent connections."
+HOMEPAGE = "https://github.com/studio-ousia/mprpc"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4ba825394aec026b5f94edca44426859"
+
+DEPENDS += "${PYTHON_PN}-gevent"
+RDEPENDS_${PN} += "${PYTHON_PN}-gevent ${PYTHON_PN}-msgpack ${PYTHON_PN}-gsocketpool"
+
+SRC_URI[md5sum] = "8d97961051422f3de315613434982d3b"
+SRC_URI[sha256sum] = "3589fd127482e291b1ec314d6f0e55cc13311c12932ace356d6178ea1ca28f6a"
+
+inherit pypi setuptools