aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Kolbus <peter.kolbus@garmin.com>2020-01-02 12:37:42 -0600
committerTim Orling <ticotimo@gmail.com>2020-01-22 19:29:12 -0800
commitc3708e7f025f688b03c60b500b1417ea0e630b4f (patch)
treef7ca23234bf58201beaa72f740d7b13aaf36bd08
parent416135458fdb6634f901c9e177d4b0685b32548b (diff)
downloadmeta-python2-c3708e7f025f688b03c60b500b1417ea0e630b4f.tar.gz
python-booleanpy: add recipe
boolean.py is a library to define and parse boolean algebras. It is used by python3-license-expression. (From meta-openembedded commit: 8cb441b64045bb2edddf46b5d6b0c0713cbc55a0) Signed-off-by: Peter Kolbus <peter.kolbus@garmin.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Refactored to add py2 recipe Signed-off-by: Tim Orling <ticotimo@gmail.com>
-rw-r--r--recipes-devtools/python/python-booleanpy_3.7.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/recipes-devtools/python/python-booleanpy_3.7.bb b/recipes-devtools/python/python-booleanpy_3.7.bb
new file mode 100644
index 0000000..feb9062
--- /dev/null
+++ b/recipes-devtools/python/python-booleanpy_3.7.bb
@@ -0,0 +1,14 @@
+SUMMARY = "Define boolean algebras, create and parse boolean expressions and create custom boolean DSL"
+HOMEPAGE = "https://github.com/bastikr/boolean.py"
+
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e319747a5eb94cddf646037c01ddba47"
+
+SRC_URI[md5sum] = "1189d115a38f84f5df743014926a9159"
+SRC_URI[sha256sum] = "bd19b412435611ecc712603d0fd7d0e280e24698e7a6e3d5f610473870c5dd1e"
+
+PYPI_PACKAGE = "boolean.py"
+
+inherit pypi setuptools
+
+BBCLASSEXTEND = "native nativesdk"