aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-opie/opie-restartapplet
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-opie/opie-restartapplet
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-opie/opie-restartapplet')
-rw-r--r--recipes-opie/opie-restartapplet/opie-restartapplet.inc15
-rw-r--r--recipes-opie/opie-restartapplet/opie-restartapplet2_1.2.5.bb21
-rw-r--r--recipes-opie/opie-restartapplet/opie-restartapplet2_cvs.bb18
-rw-r--r--recipes-opie/opie-restartapplet/opie-restartapplet_1.2.5.bb8
-rw-r--r--recipes-opie/opie-restartapplet/opie-restartapplet_cvs.bb6
5 files changed, 68 insertions, 0 deletions
diff --git a/recipes-opie/opie-restartapplet/opie-restartapplet.inc b/recipes-opie/opie-restartapplet/opie-restartapplet.inc
new file mode 100644
index 0000000..86c1f4c
--- /dev/null
+++ b/recipes-opie/opie-restartapplet/opie-restartapplet.inc
@@ -0,0 +1,15 @@
+DESCRIPTION = "Restart Applet"
+SECTION = "opie/applets"
+PRIORITY = "optional"
+LICENSE = "GPL"
+APPNAME = "restartapplet"
+
+
+S = "${WORKDIR}/${APPNAME}"
+
+inherit opie
+
+# FILES plugins/applets/librestartapplet.so*
+do_install() {
+}
+
diff --git a/recipes-opie/opie-restartapplet/opie-restartapplet2_1.2.5.bb b/recipes-opie/opie-restartapplet/opie-restartapplet2_1.2.5.bb
new file mode 100644
index 0000000..93cedc6
--- /dev/null
+++ b/recipes-opie/opie-restartapplet/opie-restartapplet2_1.2.5.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Restart Applet"
+SECTION = "opie/applets"
+PRIORITY = "optional"
+LICENSE = "GPL"
+APPNAME = "restartapplet"
+
+SRC_URI = "http://sources.openembedded.org/opie-1.2.5-split_core_applets_restartapplet2.tar.bz2;name=split_core_applets_restartapplet2 \
+ http://sources.openembedded.org/opie-1.2.5-split_apps.tar.bz2;name=split_apps"
+SRC_URI[split_core_applets_restartapplet2.md5sum] = "d5fedf3676bc08e865cc12750c11467a"
+SRC_URI[split_core_applets_restartapplet2.sha256sum] = "85a622e7ad4767b065f6ea3464af7d9f839f440bc8fa6bbeab6571a7ab66623f"
+SRC_URI[split_apps.md5sum] = "c765d13427e4dc8ee396e4dfed2dbe73"
+SRC_URI[split_apps.sha256sum] = "0fea454d8d286f7febc7449e4a06f73e941e8b22e9bab904a32e57f35479862a"
+
+S = "${WORKDIR}/restartapplet2"
+
+inherit opie
+
+# FILES plugins/applets/librestartapplet.so*
+do_install() {
+}
+
diff --git a/recipes-opie/opie-restartapplet/opie-restartapplet2_cvs.bb b/recipes-opie/opie-restartapplet/opie-restartapplet2_cvs.bb
new file mode 100644
index 0000000..507f06d
--- /dev/null
+++ b/recipes-opie/opie-restartapplet/opie-restartapplet2_cvs.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Restart Applet"
+SECTION = "opie/applets"
+PRIORITY = "optional"
+LICENSE = "GPL"
+PV = "${OPIE_GIT_PV}"
+APPNAME = "restartapplet"
+
+SRC_URI = "${OPIE_GIT};protocol=git;subpath=core/applets/restartapplet2 \
+ ${OPIE_GIT};protocol=git;subpath=apps"
+
+S = "${WORKDIR}/restartapplet2"
+
+inherit opie
+
+# FILES plugins/applets/librestartapplet.so*
+do_install() {
+}
+
diff --git a/recipes-opie/opie-restartapplet/opie-restartapplet_1.2.5.bb b/recipes-opie/opie-restartapplet/opie-restartapplet_1.2.5.bb
new file mode 100644
index 0000000..22600a2
--- /dev/null
+++ b/recipes-opie/opie-restartapplet/opie-restartapplet_1.2.5.bb
@@ -0,0 +1,8 @@
+require ${PN}.inc
+
+SRC_URI = "http://sources.openembedded.org/opie-1.2.5-split_core_applets_restartapplet.tar.bz2;name=split_core_applets_restartapplet \
+ http://sources.openembedded.org/opie-1.2.5-split_apps.tar.bz2;name=split_apps"
+SRC_URI[split_core_applets_restartapplet.md5sum] = "2d327d372cf085ccf0f932086ab5df63"
+SRC_URI[split_core_applets_restartapplet.sha256sum] = "d15e939a2d28fddbaa939828efeb134d135269316a7c5ceea354fd25e3836995"
+SRC_URI[split_apps.md5sum] = "c765d13427e4dc8ee396e4dfed2dbe73"
+SRC_URI[split_apps.sha256sum] = "0fea454d8d286f7febc7449e4a06f73e941e8b22e9bab904a32e57f35479862a"
diff --git a/recipes-opie/opie-restartapplet/opie-restartapplet_cvs.bb b/recipes-opie/opie-restartapplet/opie-restartapplet_cvs.bb
new file mode 100644
index 0000000..500ce4d
--- /dev/null
+++ b/recipes-opie/opie-restartapplet/opie-restartapplet_cvs.bb
@@ -0,0 +1,6 @@
+require ${PN}.inc
+
+PV = "${OPIE_GIT_PV}"
+
+SRC_URI = "${OPIE_GIT};protocol=git;subpath=core/applets/restartapplet \
+ ${OPIE_GIT};protocol=git;subpath=apps"