aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-extended
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-extended')
-rw-r--r--meta-python/recipes-extended/python-meh/python3-meh_0.52.bb (renamed from meta-python/recipes-extended/python-meh/python3-meh_0.51.bb)2
-rw-r--r--meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.48.bb6
-rw-r--r--meta-python/recipes-extended/python-rich/python3-rich_13.8.0.bb (renamed from meta-python/recipes-extended/python-rich/python3-rich_13.7.0.bb)2
-rw-r--r--meta-python/recipes-extended/python3-portalocker/python3-portalocker_2.10.1.bb (renamed from meta-python/recipes-extended/python3-portalocker/python3-portalocker_2.8.2.bb)2
4 files changed, 6 insertions, 6 deletions
diff --git a/meta-python/recipes-extended/python-meh/python3-meh_0.51.bb b/meta-python/recipes-extended/python-meh/python3-meh_0.52.bb
index e83514af1b..266b94c9d8 100644
--- a/meta-python/recipes-extended/python-meh/python3-meh_0.51.bb
+++ b/meta-python/recipes-extended/python-meh/python3-meh_0.52.bb
@@ -11,6 +11,6 @@ S = "${WORKDIR}/git"
SRC_URI = "git://github.com/rhinstaller/python-meh.git;protocol=https;branch=master"
-SRCREV = "eb5d4adc3b838704b6a68f0f77ada2063a11ab1b"
+SRCREV = "f0fcc3ce1943dce9cf958f4a2f7398daff619c9f"
FILES:${PN} += "${datadir}/python-meh"
diff --git a/meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.48.bb b/meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.48.bb
index 953068f7c3..a7bd8ae437 100644
--- a/meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.48.bb
+++ b/meta-python/recipes-extended/python-pykickstart/python3-pykickstart_3.48.bb
@@ -5,13 +5,13 @@ LICENSE = "GPL-2.0-or-later"
LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b"
FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
-DEPENDS = "python3"
+inherit python_setuptools_build_meta
+
RDEPENDS:${PN} = "python3 \
python3-requests \
python3-six \
"
-S = "${WORKDIR}/git"
SRC_URI = "git://github.com/rhinstaller/pykickstart.git;protocol=https;branch=master \
file://0001-support-authentication-for-kickstart.patch \
file://0002-pykickstart-parser.py-add-lock-for-readKickstart-and.patch \
@@ -22,4 +22,4 @@ SRCREV = "fa6c80c0e5c6bee29d089899a10d26e6f7f8afd8"
UPSTREAM_CHECK_GITTAGREGEX = "r(?P<pver>\d+(\.\d+)+(-\d+)*)"
-inherit setuptools3
+S = "${WORKDIR}/git"
diff --git a/meta-python/recipes-extended/python-rich/python3-rich_13.7.0.bb b/meta-python/recipes-extended/python-rich/python3-rich_13.8.0.bb
index 959f0d51aa..ee66c35541 100644
--- a/meta-python/recipes-extended/python-rich/python3-rich_13.7.0.bb
+++ b/meta-python/recipes-extended/python-rich/python3-rich_13.8.0.bb
@@ -8,7 +8,7 @@ LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=b5f0b94fbc94f5ad9ae4efcf8a778303"
-SRC_URI[sha256sum] = "5cb5123b5cf9ee70584244246816e9114227e0b98ad9176eede6ad54bf5403fa"
+SRC_URI[sha256sum] = "a5ac1f1cd448ade0d59cc3356f7db7a7ccda2c8cbae9c7a90c28ff463d3e91f4"
inherit pypi python_poetry_core
diff --git a/meta-python/recipes-extended/python3-portalocker/python3-portalocker_2.8.2.bb b/meta-python/recipes-extended/python3-portalocker/python3-portalocker_2.10.1.bb
index c45a3fcda2..8c03398ed1 100644
--- a/meta-python/recipes-extended/python3-portalocker/python3-portalocker_2.8.2.bb
+++ b/meta-python/recipes-extended/python3-portalocker/python3-portalocker_2.10.1.bb
@@ -4,7 +4,7 @@ LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=152634da660a374ca18c0734ed07c63c"
-SRC_URI[sha256sum] = "2b035aa7828e46c58e9b31390ee1f169b98e1066ab10b9a6a861fe7e25ee4f33"
+SRC_URI[sha256sum] = "ef1bf844e878ab08aee7e40184156e1151f228f103aa5c6bd0724cc330960f8f"
DEPENDS += "python3-setuptools-scm-native"