aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-xlsxwriter_3.0.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-xlsxwriter_3.0.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-xlsxwriter_3.0.2.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-xlsxwriter_3.0.2.bb b/meta-python/recipes-devtools/python/python3-xlsxwriter_3.0.2.bb
new file mode 100644
index 0000000000..04f25532a6
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-xlsxwriter_3.0.2.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Python 2 and 3 compatibility library"
+HOMEPAGE = "https://xlsxwriter.readthedocs.io"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e5c795ec8cf90514a6d844b1d3cc3224"
+
+inherit pypi setuptools3
+
+PYPI_PACKAGE = "XlsxWriter"
+
+RDEPENDS:${PN} += " \
+ python3-crypt \
+ python3-datetime \
+ python3-compression \
+ python3-numbers \
+ python3-io \
+"
+
+SRC_URI[sha256sum] = "53005f03e8eb58f061ebf41d5767c7495ee0772c2396fe26b7e0ca22fa9c2570"
+
+BBCLASSEXTEND = "native nativesdk"