aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-sympy_1.12.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-sympy_1.12.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-sympy_1.12.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-sympy_1.12.bb b/meta-python/recipes-devtools/python/python3-sympy_1.12.bb
new file mode 100644
index 0000000000..088dda3a2a
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-sympy_1.12.bb
@@ -0,0 +1,15 @@
+SUMMARY = "Computer algebra system (CAS) in Python"
+HOMEPAGE = "https://pypi.org/project/sympy/"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ea48085d7dff75b49271b25447e8cdca"
+
+SRC_URI[sha256sum] = "ebf595c8dac3e0fdc4152c51878b498396ec7f30e7a914d6071e674d49420fb8"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+ python3-misc \
+ python3-mpmath \
+"
+
+BBCLASSEXTEND = "native nativesdk"