aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-rlp_4.0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-rlp_4.0.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-rlp_4.0.1.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-rlp_4.0.1.bb b/meta-python/recipes-devtools/python/python3-rlp_4.0.1.bb
new file mode 100644
index 0000000000..46ca600ea2
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-rlp_4.0.1.bb
@@ -0,0 +1,16 @@
+SUMMARY = "A Python implementation of Recursive Length Prefix encoding (RLP)."
+HOMEPAGE = "https://github.com/ethereum/pyrlp"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=00854fa80a84236706b11f47f23e61e7"
+
+SRC_URI[sha256sum] = "bcefb11013dfadf8902642337923bd0c786dc8a27cb4c21da6e154e52869ecb1"
+
+inherit pypi setuptools3
+
+DEPENDS += "python3-pip-native"
+
+RDEPENDS:${PN} += " \
+ python3-eth-utils \
+ python3-typing-extensions \
+"