aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-gcovr_7.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-gcovr_7.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-gcovr_7.2.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-gcovr_7.2.bb b/meta-python/recipes-devtools/python/python3-gcovr_7.2.bb
new file mode 100644
index 0000000000..517124742a
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-gcovr_7.2.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "generate GCC code coverage reports"
+HOMEPAGE = "https://gcovr.com"
+SECTION = "devel/python"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c5a58ca91c1758a53f896ba89d8aaac2"
+
+SRC_URI = "git://github.com/gcovr/gcovr.git;branch=main;protocol=https"
+SRCREV = "c4b74b0859611283be646d590c7915e787911b6f"
+
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+
+RDEPENDS:${PN} += " \
+ python3-colorlog \
+ python3-jinja2 \
+ python3-lxml \
+ python3-multiprocessing \
+ python3-pygments \
+ python3-setuptools \
+"
+
+BBCLASSEXTEND = "native nativesdk"