aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-distro_1.9.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-distro_1.9.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-distro_1.9.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-distro_1.9.0.bb b/meta-python/recipes-devtools/python/python3-distro_1.9.0.bb
new file mode 100644
index 0000000000..08a9526783
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-distro_1.9.0.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Distro is an OS platform information API"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314"
+
+PYPI_PACKAGE = "distro"
+
+SRC_URI[sha256sum] = "2fa77c6fd8940f116ee1d6b94a2f90b13b5ea8d019b98bc8bafdcabcdd9bdbed"
+
+inherit pypi python_setuptools_build_meta
+
+RDEPENDS:${PN} = "\
+ python3-core \
+ python3-json \
+ python3-logging \
+ python3-shell \
+"
+
+BBCLASSEXTEND = "native nativesdk"