aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-autobahn_23.6.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-autobahn_23.6.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-autobahn_23.6.2.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-autobahn_23.6.2.bb b/meta-python/recipes-devtools/python/python3-autobahn_23.6.2.bb
new file mode 100644
index 0000000000..d9cc40b1b4
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-autobahn_23.6.2.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "WebSocket client & server library, WAMP real-time framework"
+HOMEPAGE = "http://crossbar.io/autobahn"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3e2c2c2cc2915edc5321b0e6b1d3f5f8"
+
+SRC_URI[sha256sum] = "ec9421c52a2103364d1ef0468036e6019ee84f71721e86b36fe19ad6966c1181"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+ python3-twisted \
+ python3-zopeinterface \
+ python3-py-ubjson \
+ python3-cbor2 \
+ python3-u-msgpack-python \
+ python3-lz4 \
+ python3-snappy \
+ python3-pyopenssl \
+ python3-txaio \
+ python3-six \
+"