aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-aiodns_3.2.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-aiodns_3.2.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-aiodns_3.2.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-aiodns_3.2.0.bb b/meta-python/recipes-devtools/python/python3-aiodns_3.2.0.bb
new file mode 100644
index 0000000000..bf3f1312d2
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-aiodns_3.2.0.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Simple DNS resolver for asyncio"
+DESCRIPTION = "aiodns provides a simple way for doing asynchronous DNS resolutions using pycares."
+HOMEPAGE = "https://github.com/saghul/aiodns"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=a565d8b5d06b9620968a135a2657b093"
+
+SRC_URI[sha256sum] = "62869b23409349c21b072883ec8998316b234c9a9e36675756e8e317e8768f72"
+
+PYPI_PACKAGE = "aiodns"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+ python3-asyncio \
+ python3-pycares \
+"
+
+BBCLASSEXTEND = "native nativesdk"