aboutsummaryrefslogtreecommitdiffstats
path: root/meta-perl/recipes-perl/libtext/libtext-diff-perl_1.41.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-perl/recipes-perl/libtext/libtext-diff-perl_1.41.bb')
-rw-r--r--meta-perl/recipes-perl/libtext/libtext-diff-perl_1.41.bb13
1 files changed, 10 insertions, 3 deletions
diff --git a/meta-perl/recipes-perl/libtext/libtext-diff-perl_1.41.bb b/meta-perl/recipes-perl/libtext/libtext-diff-perl_1.41.bb
index b6f7495eb2..9dfadde8e5 100644
--- a/meta-perl/recipes-perl/libtext/libtext-diff-perl_1.41.bb
+++ b/meta-perl/recipes-perl/libtext/libtext-diff-perl_1.41.bb
@@ -8,20 +8,27 @@ SECTION = "libs"
HOMEPAGE = "http://search.cpan.org/~ovid/Text-Diff/"
-LICENSE = "Artistic-1.0 | GPL-2.0+"
+LICENSE = "Artistic-1.0 | GPL-2.0-or-later"
LIC_FILES_CHKSUM = "file://LICENSE;md5=385c55653886acac3821999a3ccd17b3"
-SRC_URI = "${CPAN_MIRROR}/authors/id/O/OV/OVID/Text-Diff-${PV}.tar.gz"
+SRC_URI = "${CPAN_MIRROR}/authors/id/O/OV/OVID/Text-Diff-${PV}.tar.gz \
+ file://run-ptest \
+ "
SRC_URI[md5sum] = "30d56e6dd5551ca16b8e16cc7299dc21"
SRC_URI[sha256sum] = "a67f50a48e313c1680cc662109ce5f913ea71454db355d0cf4db87ac89d2d2fa"
S = "${WORKDIR}/Text-Diff-${PV}"
-inherit cpan
+inherit cpan ptest
+RDEPENDS:${PN}-ptest += "perl-module-test perl-module-test-more"
RDEPENDS:${PN} = " libalgorithm-diff-perl \
perl-module-extutils-makemaker \
perl-module-exporter \
"
+do_install_ptest () {
+ cp -r ${B}/t ${D}${PTEST_PATH}
+}
+
BBCLASSEXTEND = "native"