aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/smarty/smarty_4.4.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/smarty/smarty_4.4.1.bb')
-rw-r--r--meta-oe/recipes-support/smarty/smarty_4.4.1.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/smarty/smarty_4.4.1.bb b/meta-oe/recipes-support/smarty/smarty_4.4.1.bb
new file mode 100644
index 0000000000..1caa4cd1bb
--- /dev/null
+++ b/meta-oe/recipes-support/smarty/smarty_4.4.1.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "the compiling PHP template engine"
+SECTION = "console/network"
+HOMEPAGE = "https://www.smarty.net/"
+
+LICENSE = "GPL-3.0-only"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2c0f216b2120ffc367e20f2b56df51b3"
+
+DEPENDS += "php"
+
+SRC_URI = "git://github.com/smarty-php/smarty.git;protocol=https;branch=support/4.3"
+
+SRCREV = "f4152e9b814ae2369b6e4935c05e1e0c3654318d"
+
+S = "${WORKDIR}/git"
+
+do_install() {
+ install -d ${D}${datadir}/php/smarty3/libs/
+ install -m 0644 ${S}/libs/*.php ${D}${datadir}/php/smarty3/libs/
+
+ install -d ${D}${datadir}/php/smarty3/libs/plugins
+ install -m 0644 ${S}/libs/plugins/*.php ${D}${datadir}/php/smarty3/libs/plugins/
+
+ install -d ${D}${datadir}/php/smarty3/libs/sysplugins
+ install -m 0644 ${S}/libs/sysplugins/*.php ${D}${datadir}/php/smarty3/libs/sysplugins/
+}
+FILES:${PN} = "${datadir}/php/smarty3/"