aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libmxml/libmxml_3.3.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/libmxml/libmxml_3.3.1.bb')
-rw-r--r--meta-oe/recipes-support/libmxml/libmxml_3.3.1.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libmxml/libmxml_3.3.1.bb b/meta-oe/recipes-support/libmxml/libmxml_3.3.1.bb
new file mode 100644
index 0000000000..38e270c036
--- /dev/null
+++ b/meta-oe/recipes-support/libmxml/libmxml_3.3.1.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Tiny XML Library"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+HOMEPAGE = "https://www.msweet.org/mxml/"
+BUGTRACKER = "https://github.com/michaelrsweet/mxml/issues"
+
+SRC_URI = "git://github.com/michaelrsweet/mxml.git;branch=master;protocol=https"
+SRCREV = "fd47c7d115191c8a6bce2c781ffee41e179530f2"
+S = "${WORKDIR}/git"
+
+# Package does not support out of tree builds.
+inherit autotools-brokensep
+
+PACKAGECONFIG ??= "threads"
+PACKAGECONFIG[threads] = "--enable-threads,--disable-threads"
+
+# MXML uses autotools but it explicitly states it does not support autoheader.
+EXTRA_AUTORECONF = "--exclude=autopoint,autoheader"
+
+do_configure:prepend() {
+ # Respect optimization CFLAGS specified by OE.
+ sed -e 's/-Os -g//' -i ${S}/configure.ac
+
+ # Enable verbose compilation output. This is required for extra QA checks to work.
+ sed -e '/.SILENT:/d' -i ${S}/Makefile.in
+}
+
+do_install() {
+ # Package uses DSTROOT instread of standard DESTDIR to specify install location.
+ oe_runmake install DSTROOT=${D}
+}