aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/libcbor/libcbor_0.11.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-extended/libcbor/libcbor_0.11.0.bb')
-rwxr-xr-xmeta-oe/recipes-extended/libcbor/libcbor_0.11.0.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/libcbor/libcbor_0.11.0.bb b/meta-oe/recipes-extended/libcbor/libcbor_0.11.0.bb
new file mode 100755
index 0000000000..0e15393dd5
--- /dev/null
+++ b/meta-oe/recipes-extended/libcbor/libcbor_0.11.0.bb
@@ -0,0 +1,14 @@
+SUMMARY = "library for CBOR"
+DESCRIPTION = "C library for parsing and generating CBOR, the general-purpose schema-less binary data format."
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.md;md5=6f3b3881df62ca763a02d359a6e94071"
+
+SRC_URI = "git://github.com/PJK/libcbor.git;protocol=https;branch=master"
+SRCREV = "170bee2b82cdb7b2ed25af301f62cb6efdd40ec1"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+EXTRA_OECMAKE += "-DCMAKE_BUILD_TYPE=Release -DBUILD_SHARED_LIBS:BOOL=ON"