aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/libbacktrace/libbacktrace_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-extended/libbacktrace/libbacktrace_git.bb')
-rw-r--r--meta-oe/recipes-extended/libbacktrace/libbacktrace_git.bb16
1 files changed, 9 insertions, 7 deletions
diff --git a/meta-oe/recipes-extended/libbacktrace/libbacktrace_git.bb b/meta-oe/recipes-extended/libbacktrace/libbacktrace_git.bb
index 609e55f4ac..0c2382fe85 100644
--- a/meta-oe/recipes-extended/libbacktrace/libbacktrace_git.bb
+++ b/meta-oe/recipes-extended/libbacktrace/libbacktrace_git.bb
@@ -10,21 +10,23 @@ DEPENDS += "libunwind"
SRC_URI = "git://github.com/ianlancetaylor/libbacktrace;protocol=https;branch=master"
-PV = "1.0+git${SRCPV}"
-SRCREV = "4f57c999716847e45505b3df170150876b545088"
+PV = "1.0+git"
+SRCREV = "9ae4f4ae4481b1e69d38ed810980d33103544613"
+
+# The current PV is not a git tag but a README content
+UPSTREAM_CHECK_COMMITS = "1"
S = "${WORKDIR}/git"
inherit autotools
-EXTR_OECONF += "--with-system-libunwind"
-
-CFLAGS += "-fPIC"
+EXTRA_OECONF += "--with-system-libunwind --enable-shared --disable-static"
do_configure() {
oe_runconf
}
-# libunwind does not support RISCV yet
-COMPATIBLE_HOST:riscv64 = "null"
+RDEPENDS:${PN}-dev = ""
+
+# libunwind does not support RISCV32 yet
COMPATIBLE_HOST:riscv32 = "null"