aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/iptraf/iptraf-ng
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/iptraf/iptraf-ng')
-rw-r--r--meta-oe/recipes-devtools/iptraf/iptraf-ng/0001-Fix-printd-formatting-strings.patch54
-rw-r--r--meta-oe/recipes-devtools/iptraf/iptraf-ng/ncurses-config.patch81
2 files changed, 135 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/iptraf/iptraf-ng/0001-Fix-printd-formatting-strings.patch b/meta-oe/recipes-devtools/iptraf/iptraf-ng/0001-Fix-printd-formatting-strings.patch
new file mode 100644
index 0000000000..5b9afd9616
--- /dev/null
+++ b/meta-oe/recipes-devtools/iptraf/iptraf-ng/0001-Fix-printd-formatting-strings.patch
@@ -0,0 +1,54 @@
+From 86b4d398dbb95e2437b70eba3b30e995ec9be505 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Thu, 31 Aug 2017 20:47:50 -0700
+Subject: [PATCH] Fix printd formatting strings
+
+Fixes
+error: format string is not a string literal (potentially insecure) [-Werror,-Wformat-security]
+
+Upstream-Status: Pending
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/ipfilter.c | 2 +-
+ src/othptab.c | 4 ++--
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/ipfilter.c b/src/ipfilter.c
+index eb17ec7..8c76e4c 100644
+--- a/src/ipfilter.c
++++ b/src/ipfilter.c
+@@ -146,7 +146,7 @@ void gethostparams(struct hostparams *data, char *init_saddr, char *init_smask,
+ snprintf(msgstr, 60,
+ "Invalid protocol input at or near token \"%s\"",
+ bptr);
+- tui_error(ANYKEY_MSG, msgstr);
++ tui_error(ANYKEY_MSG, "%s", msgstr);
+ doagain = 1;
+ } else
+ doagain = 0;
+diff --git a/src/othptab.c b/src/othptab.c
+index 142c9c2..fe395c2 100644
+--- a/src/othptab.c
++++ b/src/othptab.c
+@@ -410,7 +410,7 @@ void printothpentry(struct othptable *table, struct othptabent *entry,
+ break;
+ }
+
+- sprintf(scratchpad, rarp_mac_addr);
++ sprintf(scratchpad, "%s", rarp_mac_addr);
+ strcat(msgstring, scratchpad);
+ wattrset(table->othpwin, ARPATTR);
+ break;
+@@ -485,7 +485,7 @@ void printothpentry(struct othptable *table, struct othptabent *entry,
+ wattrset(table->othpwin, UNKNIPATTR);
+ protptr = getprotobynumber(entry->protocol);
+ if (protptr != NULL) {
+- sprintf(protname, protptr->p_aliases[0]);
++ sprintf(protname, "%s", protptr->p_aliases[0]);
+ } else {
+ sprintf(protname, "IP protocol");
+ unknown = 1;
+--
+2.14.1
+
diff --git a/meta-oe/recipes-devtools/iptraf/iptraf-ng/ncurses-config.patch b/meta-oe/recipes-devtools/iptraf/iptraf-ng/ncurses-config.patch
new file mode 100644
index 0000000000..65b92dade2
--- /dev/null
+++ b/meta-oe/recipes-devtools/iptraf/iptraf-ng/ncurses-config.patch
@@ -0,0 +1,81 @@
+Use pkg-config to search for ncurses libraries
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+Upstream-Status: Pending
+Index: iptraf-ng-1.1.4/Makefile
+===================================================================
+--- iptraf-ng-1.1.4.orig/Makefile
++++ iptraf-ng-1.1.4/Makefile
+@@ -205,8 +205,8 @@ endif
+
+ ifndef NCURSES_LDFLAGS
+ ifdef NEEDS_NCURSES5
+- NCURSES_CFLAGS := $(shell ncurses5-config --cflags 2>/dev/null)
+- NCURSES_LDFLAGS := $(shell ncurses5-config --libs 2>/dev/null)
++ NCURSES_CFLAGS := $(shell pkg-config ncurses --cflags 2>/dev/null)
++ NCURSES_LDFLAGS := $(shell pkg-config ncurses --libs 2>/dev/null)
+ ifndef NO_PANEL
+ NCURSES_LDFLAGS += -lpanel
+ endif
+@@ -215,8 +215,8 @@ endif
+
+ ifndef NCURSES_LDFLAGS
+ ifdef NEEDS_NCURSESW5
+- NCURSES_CFLAGS := $(shell ncursesw5-config --cflags 2>/dev/null)
+- NCURSES_LDFLAGS := $(shell ncursesw5-config --libs 2>/dev/null)
++ NCURSES_CFLAGS := $(shell p[k-config ncursesw --cflags 2>/dev/null)
++ NCURSES_LDFLAGS := $(shell pkg-config ncursesw --libs 2>/dev/null)
+ ifndef NO_PANEL
+ NCURSES_LDFLAGS += -lpanel
+ endif
+@@ -225,8 +225,8 @@ endif
+
+ ifndef NCURSES_LDFLAGS
+ ifdef NEEDS_NCURSES6
+- NCURSES_CFLAGS := $(shell ncurses6-config --cflags 2>/dev/null)
+- NCURSES_LDFLAGS := $(shell ncurses6-config --libs 2>/dev/null)
++ NCURSES_CFLAGS := $(shell pkg-config ncurses6 --cflags 2>/dev/null)
++ NCURSES_LDFLAGS := $(shell pkg-config ncurses6 --libs 2>/dev/null)
+ ifndef NO_PANEL
+ NCURSES_LDFLAGS += -lpanel
+ endif
+@@ -235,8 +235,8 @@ endif
+
+ ifndef NCURSES_LDFLAGS
+ ifdef NEEDS_NCURSESW6
+- NCURSES_CFLAGS := $(shell ncursesw6-config --cflags 2>/dev/null)
+- NCURSES_LDFLAGS := $(shell ncursesw6-config --libs 2>/dev/null)
++ NCURSES_CFLAGS := $(shell pkg-config ncursesw --cflags 2>/dev/null)
++ NCURSES_LDFLAGS := $(shell pkg-config ncursesw --libs 2>/dev/null)
+ ifndef NO_PANEL
+ NCURSES_LDFLAGS += -lpanel
+ endif
+@@ -246,17 +246,17 @@ endif
+ # try find ncuses by autodetect
+ ifndef NCURSES_LDFLAGS
+ ifneq ($(shell ncursesw6-config --libs 2>/dev/null),)
+- NCURSES_CFLAGS := $(shell ncursesw6-config --cflags 2>/dev/null)
+- NCURSES_LDFLAGS := $(shell ncursesw6-config --libs 2>/dev/null)
+- else ifneq ($(shell ncurses6-config --libs 2>/dev/null),)
+- NCURSES_CFLAGS := $(shell ncurses6-config --cflags 2>/dev/null)
+- NCURSES_LDFLAGS := $(shell ncurses6-config --libs 2>/dev/null)
+- else ifneq ($(shell ncursesw5-config --libs 2>/dev/null),)
+- NCURSES_CFLAGS := $(shell ncursesw5-config --cflags 2>/dev/null)
+- NCURSES_LDFLAGS := $(shell ncursesw5-config --libs 2>/dev/null)
+- else ifneq ($(shell ncurses5-config --libs 2>/dev/null),)
+- NCURSES_CFLAGS := $(shell ncurses5-config --cflags 2>/dev/null)
+- NCURSES_LDFLAGS := $(shell ncurses5-config --libs 2>/dev/null)
++ NCURSES_CFLAGS := $(shell pkg-config ncursesw --cflags 2>/dev/null)
++ NCURSES_LDFLAGS := $(shell pkg-config ncursesw --libs 2>/dev/null)
++ else ifneq ($(shell pkg-config ncurses --libs 2>/dev/null),)
++ NCURSES_CFLAGS := $(shell pkg-config ncurses --cflags 2>/dev/null)
++ NCURSES_LDFLAGS := $(shell pkg-config ncurses --libs 2>/dev/null)
++ else ifneq ($(shell pkg-config ncursesw --libs 2>/dev/null),)
++ NCURSES_CFLAGS := $(shell pkg-config ncursesw --cflags 2>/dev/null)
++ NCURSES_LDFLAGS := $(shell pkg-config ncursesw --libs 2>/dev/null)
++ else ifneq ($(shell pkg-config ncurses --libs 2>/dev/null),)
++ NCURSES_CFLAGS := $(shell pkg-config ncurses --cflags 2>/dev/null)
++ NCURSES_LDFLAGS := $(shell pkg-config ncurses --libs 2>/dev/null)
+ endif
+
+ ifneq ($(NCURSES_LDFLAGS),)