aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-benchmark/iperf3/iperf3_3.15.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-benchmark/iperf3/iperf3_3.15.bb')
-rw-r--r--meta-oe/recipes-benchmark/iperf3/iperf3_3.15.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-oe/recipes-benchmark/iperf3/iperf3_3.15.bb b/meta-oe/recipes-benchmark/iperf3/iperf3_3.15.bb
new file mode 100644
index 0000000000..156bb5a3e4
--- /dev/null
+++ b/meta-oe/recipes-benchmark/iperf3/iperf3_3.15.bb
@@ -0,0 +1,31 @@
+SUMMARY = "Network benchmark tool"
+DESCRIPTION = "\
+iperf is a tool for active measurements of the maximum achievable bandwidth \
+on IP networks. It supports tuning of various parameters related to timing, \
+protocols, and buffers. For each test it reports the bandwidth, loss, and \
+other parameters."
+
+HOMEPAGE = "http://software.es.net/iperf/"
+SECTION = "console/network"
+BUGTRACKER = "https://github.com/esnet/iperf/issues"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=dc6301c8256ceb8f71c9e3c2ae9096b9"
+
+SRC_URI = "git://github.com/esnet/iperf.git;branch=master;protocol=https \
+ file://0002-Remove-pg-from-profile_CFLAGS.patch \
+ file://0001-configure.ac-check-for-CPP-prog.patch \
+ "
+
+SRCREV = "917d2f02188f6f4cdc443df7923a4bde72017d92"
+
+S = "${WORKDIR}/git"
+
+inherit autotools
+
+PACKAGECONFIG ?= "openssl"
+
+PACKAGECONFIG[lksctp] = "ac_cv_header_netinet_sctp_h=yes,ac_cv_header_netinet_sctp_h=no,lksctp-tools"
+PACKAGECONFIG[openssl] = "--with-openssl=${RECIPE_SYSROOT}${prefix},--without-openssl,openssl"
+
+CFLAGS += "-D_GNU_SOURCE"